Bug #28314 Wrongly update the user password
Submitted: 8 May 2007 21:09 Modified: 11 Feb 2009 9:53
Reporter: Frank Liu Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.2.11 OS:Microsoft Windows (Windows XP)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: password

[8 May 2007 21:09] Frank Liu
Description:
If a username is associated with two or more hosts, when you update one password for one host in the MySQL Administator, other passwords linked to this name for other hosts are updated at the same time. This means all the passwords for one username with all hosts are all the same at anytime if you update them with MySQL Administrator.

This problem occurs only when I update the passwords. It is no problem if I update the privileges of the user. They are updated individually.

How to repeat:
Enter the Administrator, within User Administrator, add a new user, and add two different hosts. Assign different passwords to them. You will find only one password is available. This can be confirmed by MySQL Query Brower when you get the data of the table user in database mysql. You can see all the passwords associated with the same username are the same, and when you update one in Adminstrator and refresh the result tab in Query Brower, other passwords for the same username are updated to the same value at the same time.
[8 May 2007 23:22] MySQL Verification Team
Thank you for the bug report.
[11 Feb 2009 9:53] Mike Lischke
This is by design. A user only has one password, regardless from where he connects. Only access rights can be specified per host.