Bug #28301 User priviledges Delete-not working properly
Submitted: 8 May 2007 10:31 Modified: 8 May 2007 10:38
Reporter: Heikki Mustonen Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.24 OS:Any
Assigned to: CPU Architecture:Any
Tags: delete, user priviledges

[8 May 2007 10:31] Heikki Mustonen
I tried to create an user to mysql database. This user would only has rights to delete (security reasons). I tried to use regular delete-command but it ended for failure. 

SELECT command denied to user 'blaablaa'@'blablaa.gateway' for column 'id' in table 'misc_re'
DELETE FROM misc_re WHERE id=30 

When I added this person right to use "SELECT"-commands this works just fine.. but then I'm losing the advantage of using this feature.

How to repeat:
1. Create new user
2. Give the person rights only for DELETE-queries
3. Try to perform Delete-query
[8 May 2007 10:38] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

You implicitly SELECT from the table, because you use WHERE clause to find the row.