Bug #27933 UTF-8 PHP and MySQL GUI Browser incompatibily
Submitted: 18 Apr 2007 16:59 Modified: 18 Apr 2007 20:10
Reporter: agf affgf Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Charsets Severity:S3 (Non-critical)
Version:Mysql 5.0.37 gui-tools-5.0-r11-win32 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[18 Apr 2007 16:59] agf affgf
Description:
I set mysql table character set to utf-8 and also the html meta tag in the php document: content="text/html; charset=utf-8"

When I enter Chinese text through the Mysql GUI Browser, I can read it correctly in the GUI. However, when I get the same data to a web page using PHP, it is an unreadable mass of characters, like this: 巴西則繼續

When I enter the same Chinese text in a php web page and read it with another web page, it is OK. But viewing the same text in the Mysql GUI is unreadable: 費1個月.

So it seems that even if I use the same UTF8 character set, the GUI and PHP are not compatible with each other. They can read only their own entries but not each other's.

How to repeat:
Just follow the description above
[18 Apr 2007 20:10] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Seems connection settings (which it uses to connect to MySQL server) in your PHP script are broken. Please read about "Connection Character Sets and Collations" at http://dev.mysql.com/doc/refman/5.0/en/charset-connection.html