Bug #27861 Can't compile a client application: unresolved external symbols
Submitted: 16 Apr 2007 20:11 Modified: 8 Jan 2008 17:32
Reporter: Miguel Solorzano Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S2 (Serious)
Version:5.0.41, 5.1.17 OS:Microsoft Windows
Assigned to: Georg Richter
Tags: can't compile client, linking
Triage: D3 (Medium)

[16 Apr 2007 20:11] Miguel Solorzano
Description:
Download the mysql-noinstall-5.1.17-beta-win32.zip package and install it.
Create a VS 2005 project 32-win console client application and compile
against the mysqlclient.lib.  You will get several linkage errors like:

mysqlclient.lib(client.obj) : error LNK2001: unresolved external symbol _yaSSL_get_peer_certificate
mysqlclient.lib(viossl.obj) : error LNK2001: unresolved external symbol _yaSSL_get_peer_certificate

How to repeat:
see description

Suggested fix:
-
[9 Jun 2007 2:22] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=29001 was marked as duplicate of
this one.
[9 Jun 2007 5:37] Jim Winstead
Added 5.0.41 to version, to note this isn't just a 5.1 problem.
[9 Jun 2007 13:26] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/28461

ChangeSet@1.2518, 2007-06-09 15:26:21+02:00, georg@bing.site +1 -0
  Fix for bug #27861: unresolved externals (yassl and taocrypt):
  
  Added yassl and taocrypt sources to mysqlclientlib.
[9 Jun 2007 16:56] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/28465

ChangeSet@1.2518, 2007-06-09 18:32:40+02:00, georg@bing.site +1 -0
  Fix for bug #27861: unresolved externals (yassl and taocrypt):
  
  Added yassl and taocrypt sources to mysqlclientlib.
[9 Jun 2007 18:55] Valerii Kravchuk
Bug #28665 was marked as a duplicate of this one.
[15 Jun 2007 7:58] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/28843

ChangeSet@1.2558, 2007-06-15 09:52:58+02:00, df@pippilotta.erinye.com +1 -0
  BUG#27861 merge to 5.1
[16 Jun 2007 4:51] Bugs System
Pushed into 5.1.20-beta
[22 Dec 2007 3:53] Kent Boortz
This was corrected in 5.0.48 and 5.1.22
[8 Jan 2008 17:32] Paul Dubois
Noted in 5.0.48, 5.1.22 changelogs.

On Windows, symbols for yaSSL and taocrypt were missing from
mysqlclient.lib, resulting in unresolved symbol errors for clients
linked against that library.