Bug #27763 mysqldump doesn't work with many tables
Submitted: 11 Apr 2007 17:56 Modified: 11 Apr 2007 18:27
Reporter: Alessandro C. Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Backup Severity:S2 (Serious)
Version:MySQL 4.1.10 OS:Other (Debian 3.1)
Assigned to: CPU Architecture:Any
Tags: Backup, mysqldump, ssh

[11 Apr 2007 17:56] Alessandro C.
Description:
I want backup my database with over 1500 tables but mysql say:

/usr/local/mysql/bin/mysqldump: Got error: 1105: File './database/table.MYD' not found (Errcode: 24) when using LOCK TABLES

and every time that I try, mysql say same error(simply changing the name of the table)

How to repeat:
/usr/local/mysql/bin/mysqldump -uUSER -pPASSWORD DATABASE

Suggested fix:
Please correct this bug
[11 Apr 2007 18:27] MySQL Verification Team
Thank you for the bug report. Duplicate of bug:
http://bugs.mysql.com/bug.php?id=26026