Bug #27734 MySQL System Prefs Pane doesn't shut down server; no authentication check
Submitted: 10 Apr 2007 15:58 Modified: 22 Feb 2008 15:22
Reporter: Matt McCollow Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL GUI Common Severity:S3 (Non-critical)
Version:5.0.27 OS:Mac OS X (10.4.9)
Assigned to: Assigned Account CPU Architecture:Any
Tags: Apple, macosx, system prefs, tiger
Triage: D3 (Medium)

[10 Apr 2007 15:58] Matt McCollow
Description:
Using the MySQL Prefs Pane in Mac OS X, the "Start MySQL Server" button brings up an authentication dialog, and then starts the MySQL server as expected. Once the server is running for a while, clicking the "Stop MySQL Server" button has no effect. It should ask for authentication again (since the first session is timed out) and then shut down the instance of MySQL Server.

How to repeat:
1. Open System Preferences->MySQL
2. Click "Start MySQL Server" and authenticate yourself
3. Wait 5-10 minutes
4. Click "Stop MySQL Server"

Suggested fix:
Have the "Stop MySQL Server" button action check to see if we're still authenticated when it's clicked, and if not, ask for authentication again.

I'd imagine whatever function the Start button action uses to check for authentication can basically be copied and pasted with little modification into the Stop button action. I know zilch about Cocoa though, so I could be way off-base.
[11 Apr 2007 10:31] Sveta Smirnova
Thank you for the report.

Verified as described.
[22 Feb 2008 14:52] Mattias Jonsson
Checking if it is a duplicate of Bug#28854.
[22 Feb 2008 15:22] Mattias Jonsson
This is a duplicate of Bug#28854, it works in Leopard with the updated MySQL.prefPane.