Bug #27523 agent update on Windows does not wait long enough after stopping the agent
Submitted: 29 Mar 2007 12:52 Modified: 12 Apr 2007 13:29
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S2 (Serious)
Version:1.1.0.4973 OS:Microsoft Windows (Windows)
Assigned to: BitRock Merlin CPU Architecture:Any
Tags: Agent, service

[29 Mar 2007 12:52] Carsten Segieth
Description:
During the agent update I often (but not always) see the message, that the mysql-service-agent.exe file could not be copied from .../patchtemp to the target dir.
In a GUI update one can click on 'RETRY' and often with the first retry the problem is solved - as the time for being surprised by the error and reading it seems to be enough for really stopping the service.

But in an unattended update install no 'RETRY' is performed, and so often the unattended update fails with a message like this:

Error copying file from C:/Programme/MySQL/MySQL Network 2.0/MySQL Network 2.0/patchtemp/mysql-service-agent.exe to C:/Programme/MySQL/MySQL Network 2.0/MySQL Network 2.0/mysql-service-agent.exe
Abort

And - the unattended install then quits with ERRORLEVEL = 0, so there is no way to check in a script for success or not.

How to repeat:
"mysqlserviceagent-1.1.0.4973-windows-update-installer.exe"  --optionfile "options.agent.update.DEU.txt"  1>
"..\consprot.agent.update.VMXP2.1.1.0.4973.txt"

content of "options.agent.update.DEU.txt":
------------------------------------------
debugtrace=C:\Programme\MySQL\install.debugtrace.Agent.Update.log
installdir=C:\Programme\MySQL\MySQL Network 2.0\MySQL Network 2.0
createPatchBackup=1
mode=unattended

Suggested fix:
1) wait until the 'SC STOP servicename>' (or whatever is used) command was successfull
2) use non-zero returncode in case of errors during unattended update
[5 Apr 2007 16:03] BitRock Merlin
Patch sent to Keith. Though still not addressing the issue of exit codes, this version waits longer enough for the agent to stop
[12 Apr 2007 0:36] Keith Russell
Reported as corrected in versions => 1.1.1.5099
[12 Apr 2007 13:29] Peter Lavin
Added to changelog.