Bug #27447 agent + server update doesn't update version entry in Add/Remove Programs menu
Submitted: 26 Mar 2007 15:01 Modified: 15 Oct 2008 10:23
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version:1.1.0.4899, 2.0 OS:Microsoft Windows
Assigned to: BitRock Merlin CPU Architecture:Any
Tags: ARP, UPDATE

[26 Mar 2007 15:01] Carsten Segieth
Description:
After an agent update installation 1.0.1.4391 --> 1.1.0.4899 the version in the Add/Remove Programs Menu still shows 1.0.1.4391, although the update was successfull and the file version of the agent.exe is 1.1.0.4899 (which is correct).

How to repeat:
- install 1.0.1.43941
- update to 1.1.0.4899

Suggested fix:
change the version during update where used, e.g. in
- ARP Menu
- unInstall question ("Do you want to uninstall MyNSA <vers> and all of it's modules?")
- RegDB [HKEY_LOCAL_MACHINE\SOFTWARE\MySQL AB\MySQL Network Service Agent]
[26 Mar 2007 15:12] Carsten Segieth
Although at the moment not tested - I assume that the server update installer has the same behaviour.
[22 May 2007 7:58] Carsten Segieth
yes, the server update installer has the same behaviour
[19 Sep 2008 8:54] BitRock Merlin
We implemented a fix for this feature long ago. We have tested now using the latest versions and we can confirm that the issue is fixed, both for the Server and the Agent.

Could you please confirm that this issue is fixed on your end?
[30 Sep 2008 18:52] Carsten Segieth
- tested OK ("in general") with 2.0.0.7058, the version string is changed on update

- but if this leads to having e.g. 2 agents with the same version, like one directly installed and one updated from an older version, there will remain only one entry in the ARP menu for unInstall, as it's key in the RegDB uses the version as part of the key name.

- here it starts having two bugs for the same ARP menu problem, so please follow up for this in bug#38976.

- For the documentation this remaining problem should be noted when the fix for the version update is noted.
[15 Oct 2008 10:23] Tony Bedford
An entry was added to the 2.0 changelog:

After an agent installation was updated from 1.0.1.4391 to 1.1.0.4899, the version in the Add/Remove Programs menu was incorrectly displayed as 1.0.1.4391, even though the update was successful and the file version of agent.exe was correctly displayed as 1.1.0.4899.