Bug #27435 Error on restoring database with Administrator
Submitted: 26 Mar 2007 9:04 Modified: 10 Feb 2009 14:53
Reporter: Christian Walde-Sauer Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.2.10 OS:Microsoft Windows (Win32 (W2K))
Assigned to: Mike Lischke CPU Architecture:Any

[26 Mar 2007 9:04] Christian Walde-Sauer
Description:
I created a Database-Dump with a.m. Administrator. Then I wanted to restore the file, then it appears mostly errors like following one:

CREATE TABLE `_dateformatshort` (
  `DateFormatShortID` tinyint(3) unsigned NOT NULL default '0',
  `Caption` varchar(10) default NULL,
  PRIMARY KEY  (`DateFormatShortID`),
  KEY `DateFormatID` (`DateFormatShortID`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
Ignoring this statement. Please file a bug-report including the statement if this statement should be recognized.

I don't know what it did wrong during backup or restore.
The code works fine, if I copy a.m. code into Query Browser and run the query, so it looks like it has some problems with the restore routine.

How to repeat:
Copy SQL code into a file and try to restore database.
[26 Mar 2007 11:19] MySQL Verification Team
Thank you for the bug report. The problem is the '_' initial character
in the table name, editing the back-up file removing that character
is possible to restore the table.
[28 Mar 2007 13:55] Christian Walde-Sauer
Thanks for the response, that it is caused by "_".
But I am wondering, that the backup file works with older versions of Administrator like V1.2.3rc
[10 Feb 2009 14:53] Mike Lischke
Thank you for your bug report. This issue has already been fixed in the latest released version of that product, which you can download at

  http://www.mysql.com/downloads/