Bug #27364 Installing MNMAS on Windows Vista with AMD64 processor Fails
Submitted: 21 Mar 2007 23:42 Modified: 26 Mar 2007 23:46
Reporter: Chris Calender Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version:1.1.0.4876 OS:Microsoft Windows (Windows Vista (Home Premium))
Assigned to: BitRock Merlin CPU Architecture:Any
Tags: fixreg, segmentation fault, vista

[21 Mar 2007 23:42] Chris Calender
Description:
Installing MNMAS on Windows Vista with AMD64 processor Fails

I realize that the Windows download is for (Intel x86, 32 and 64-bit), but I tried the install anyways.

The install nearly completes and then spits out an error with php.  It then allows the installation to continue, and it finishes, but the dashboard will not open.

In the bitrock_installer.txt file, I see the following lines:

Configuring PHP (1/4)
Executing C:\Program Files\MySQL\Network\Monitoring\php\php.exe
Error running C:\Program Files\MySQL\Network\Monitoring\php\php.exe "C:\Program Files\MySQL\Network\Monitoring\php\fixreg.php" "C:\Program Files\MySQL\Network\Monitoring\dashboard\lib\.channels" @@BITROCK_PHP_ROOTDIR@@ "C:\Program Files\MySQL\Network\Monitoring\php" : child killed: segmentation violation

You'll see that it then goes on to finish the install:

Creating Uninstaller
Creating uninstaller 25%
Creating uninstaller 50%
Creating uninstaller 75%
Creating uninstaller 100%
Installation completed
Log finished 03/21/07 at 18:11:56
Executing C:/PROGRA~1/MySQL/Network/MONITO~1/mysqlnetworkctl.bat
Script output:

Launching http://localhost:10080/

How to repeat:
N/A

Suggested fix:
N/A
[22 Mar 2007 15:39] BitRock Merlin
We have been unable to reproduce this running Windows Vista Ultimate
32bits on an AMD64 machine.

Are you able to reproduce this issue in any other machine?
Are there any other applications running (antivirus, for instance)
that may prevent the installer from executing certain actions or
crashing?
How do you invoke the installer?
[22 Mar 2007 21:51] Chris Calender
I have not seen this on any others, but it was the only one I installed it on.  It is a brand new machine, and it was a fresh install.  I simply double-clicked on the installer file, went through the normal process, choosing defaults, etc.

Also, no other applications were running and I did not have any antivirus program runninng at that time.
[22 Mar 2007 22:55] Daniel Lopez
Can you reproduce it consistently in that same machine?
We have tested in several Vista versions (32/64bit, Intel/amd) and it works fine

Is it running in a VM with limited resources?
[24 Mar 2007 5:25] Chris Calender
I have not tried to re-install yet, as I wanted to hear back from you first to see if you could use any additional information.  This is not in a VM or anything like that.  It is a brand new compter and I have full admin privs.

I'll try to re-install and will let you know the outcome.  Will probably not be until Monday though. :)
[26 Mar 2007 23:46] Chris Calender
Okay, have resolved this.  I changed 2 items, and I'm not sure if both were necessary.  But one was definitely causing a problem, and other users may need the other change.

First, I did have a firewall in the way.  I "disabled" the free 30-day trial version of McAfee Protection software, however, this did not disable the McAfee firewall ;)

I had also changed a user setting, as I could not modify my my.ini, or any other files in C:\Program Files\...

I had to go to the "User Account" section in the Control Panel.  And then Turned Off "User Account Control".  Then I could modify files such as my.ini.

So, this was not a bug, and I'm closing it.