Bug #27250 Comment backcolor shown on non-commented lines
Submitted: 19 Mar 2007 0:00 Modified: 4 Feb 2009 15:00
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.2.10 OS:Microsoft Windows (WinXP)
Assigned to: Mike Lischke
Tags: backcolor, comment, gray, qc
Triage: D3 (Medium)

[19 Mar 2007 0:00] Jared S
Description:
Seems to be few instances when QB thinks a non comment line is a comment line, and shown with comment backcolor.  Here is 1 perfect scenario for you to fix.

How to repeat:
1. Type in following..

-- comment
select 1;

2. Move cursor to first line

RESULT : The second line comes up with backcolor of light gray when it is 'active' SQL text, and also results in error when executed!
[19 Mar 2007 5:16] Valerii Kravchuk
Thank you for a bug report. Verified just as described.
[21 Jun 2007 21:41] Jared S
Changing bug to S2-Serious
[4 Feb 2009 15:00] Mike Lischke
This is not a bug. There is no different back color used for comments. What you see is the effect of marking the current command in the Query Area. You can also see that by adding several lines like:

select 1;
select 2;
select 3;
select 4;

Move the caret around and you will see that always the lines which belong to an executable command get the window background when the caret is on any of the participating lines. Everything else has a gray background.