Bug #27247 Possible to create NDB and non--NDB tables with the same name
Submitted: 18 Mar 2007 14:11 Modified: 10 Dec 2007 15:26
Reporter: Grigory Rubtsov Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S3 (Non-critical)
Version:5.1.16 OS:Linux (Linux)
Assigned to: CPU Architecture:Any
Tags: cluster ndb table create
Triage: D3 (Medium)

[18 Mar 2007 14:11] Grigory Rubtsov
Description:
It is possible to create a non-NDB table on SQL node in NDB cluster and then create a NDB table (from a different SQL node) with the same name getting no error (although there is a line on the node error log).

How to repeat:
sql node 1> CREATE TABLE a (a INT) ENGINE=MyISAM;
sql node 2> CREATE TABLE a (a INT) ENGINE=NDB;

Suggested fix:
Check local table names on all SQL nodes.
[19 Mar 2007 10:31] Sveta Smirnova
Thank you for the report.

Verified as described.
[19 Mar 2007 10:32] Sveta Smirnova
test case

Attachment: ndb_bug27247.test (application/octet-stream, text), 290 bytes.

[10 Dec 2007 15:26] Martin Skold
This is deliberate behavior, local tables in other
storage engines are allowed to shadow cluster tables.
It is not recommended to use this behavior (better to use 
separate databases for local and distributed tables), 
but it is not a bug.
Current implementation will give warnings when doing SHOW TABLES;
if shadowed table are found.