Bug #27107 upable to update view in access
Submitted: 13 Mar 2007 22:32 Modified: 28 May 2013 8:16
Reporter: Philip Borgum Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51 OS:Microsoft Windows (Windows XP)
Assigned to: Bogdan Degtyariov CPU Architecture:Any
Tags: Microsoft Access

[13 Mar 2007 22:32] Philip Borgum
Description:
I am unable to update the fields in a view when connecting to the view through Microsoft Access.  I have no problem updateing the view with a similar update statement from mysql.  I get the error statement:

Operation must be an updateable query

The query is:
UPDATE MPSData SET MPSData.Work_Hours = 50
WHERE (((MPSData.Location) Like 'berm%') AND ((MPSData.Month)="January") AND ((MPSData.Year)=2007));

A similar query in mysql will succeed:

update derunit.MPSData set work_hours = NULL where location like "Birm%";

How to repeat:
It is always repeatable in Access
[14 Mar 2007 11:26] Tonci Grgin
Not enough information was provided for us to be able to handle this bug. Please re-read the instructions at http://bugs.mysql.com/how-to-report.php

If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Explanation:
Hi Philip and thanks for your report.
Please provide us with as much info as you can before you reopen it. 
For example:
 - MySQL server version
 - JET engine version
 - MyODBC version (are you using 3.51.14?)
 - DDL statements needed to reproduce the problem
 ...

You may also want to check on old bug reports. Due to lack of info provided by you, I can't say if your report is a duplicate...

http://bugs.mysql.com/bug.php?id=13930
http://bugs.mysql.com/bug.php?id=19671
http://bugs.mysql.com/bug.php?id=23122
http://bugs.mysql.com/bug.php?id=9211
http://bugs.mysql.com/bug.php?id=17725
etc.
[14 Apr 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 May 2013 8:16] Bogdan Degtyariov
Can't continue without feedback from the reporter.
Closed.