Bug #27074 Syntax font color gremlin
Submitted: 13 Mar 2007 10:10 Modified: 5 Feb 2009 10:42
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.2.10 OS:Microsoft Windows (WinXP)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: font color, qc, syntax

[13 Mar 2007 10:10] Jared S
Description:
Easy one for junior programmer.  Text of variables preped with muneric character are displayed in mixture of purple and black text.

How to repeat:
Type in..  select 1 as 1expression

RESULT '1expression' is displayed in mixture of purple and black text
[13 Mar 2007 10:13] Valeriy Kravchuk
Thank you for a bug report. Verified just as described.
[5 Feb 2009 10:42] Mike Lischke
Hmm, what exactly is the bug here? This is intended behavior and handled by most other syntax highlighting editors the same way, unless it's a language that supports identifiers that can start with a number (without extra markup like quotes etc.). The term "1expression" are two tokens: a number and an identifier. If they have been assigned two different colors (like in QB) they appear properly in their assigned colors.