Bug #27052 Access violation after confirmed 'delete table column' but before Appply Changes
Submitted: 12 Mar 2007 16:27 Modified: 29 Jan 2009 13:11
Reporter: Heinz Schweitzer (Gold Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.10 OS:Microsoft Windows (XP)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: qc
Triage: D1 (Critical)

[12 Mar 2007 16:27] Heinz Schweitzer
Description:
Access violation after confirmed 'delete table column' but before 'Appply Changes'

MySQL Administrator 1.2.10
MySQL Server Information
--------------------------------------------------------------------------------
Connected to MySQL Server Instance
  Username:                root
  Hostname:                localhost
  Port:                    3306
--------------------------------------------------------------------------------
Server Information
  MySQL Version:           MySQL 5.0.27-community-nt via TCP/IP
  Network Name:            localhost
  IP:                      127.0.0.1
--------------------------------------------------------------------------------
Client Information
  Version:                 MySQL Client Version 5.1.11
  Network Name:            xxxxxxxxxxx
  IP:                      xxxxxxxxxxx
  Operating System:        Windows XP
  Hardware:                2x Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz, 2.0 GB RAM

How to repeat:
Prerequisite:

	Have schema with a table you can fool around with

Open MySQL Administrator 1.2.10

From catalogs select a schema you can fool around with.

See screen shot d1

In the right pane activate the 'Schema Tables' tab and open a
table like t2 and say 'edit'

In the Table Editor select the field 'b' and say 'delete table column'
like in screen shot d1
Say OK in the confirm dialog.
Now go and try to select field 'a' 

----> Access Violation like in screen shot d2
[12 Mar 2007 16:28] Heinz Schweitzer
d1

Attachment: d1.jpg (image/jpeg, text), 160.46 KiB.

[12 Mar 2007 16:28] Heinz Schweitzer
d2

Attachment: d2.jpg (image/jpeg, text), 161.52 KiB.

[12 Mar 2007 17:01] Valeriy Kravchuk
Thank you for a bug report. Verified just as described. I've got "Oupt of Memory" exception on my (InnoDB) table and XP Home SP2, but it is still a bug.
[29 Jan 2009 13:11] Mike Lischke
Duplicate of Bug #29407