Bug #26959 Comma in a comment
Submitted: 8 Mar 2007 15:04 Modified: 13 Apr 2007 8:32
Reporter: amer amer Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / J Severity:S2 (Serious)
Version:any OS:Microsoft Windows (Windows)
Assigned to: Mark Matthews CPU Architecture:Any

[8 Mar 2007 15:04] amer amer
Description:
Hi,
If I enter a comma inside a comment near the parameters, it thinks the text
after the comma is a parameter!

Example: 

CREATE PROCEDURE PROC_TEST(
    _ACTION varchar(20),
    _RESULT varchar(10)    /* Generic, result parameter */

How to repeat:
Create a procedure with a few parameters, place a comment after one of them. 
I call the proceure from Cold Fusion using CFSTOREDPROC.

Suggested fix:
Ignore everything inside comments.
[8 Mar 2007 15:26] Miguel Solorzano
Thank you for the bug report.  I was unable to repeat the issue
reported within the mysql client, please try to repeat with the
mysql client if fails too, please provide the complete script
of your procedure. Thanks in advance.
[8 Mar 2007 19:13] Valeriy Kravchuk
Have you tried to create these procedures in mysql command line client? Have you got the same results (error messages)?
[8 Mar 2007 20:08] Valeriy Kravchuk
No need for additional checks. This bug is NOT repeatable with mysql command line client. It is a known problem in Connector/J (caused by a known limitations of MySQL server).
[13 Apr 2007 8:32] MC Brown
A note has been added to the 5.0.6 changelog.