Bug #26880 Again two different lists of storage engines to select from
Submitted: 6 Mar 2007 16:03 Modified: 14 May 2009 12:46
Reporter: Heinz Schweitzer (Gold Quality Contributor) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.10 OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[6 Mar 2007 16:03] Heinz Schweitzer
Description:
Again two different lists of storage engines to select from

MA in the 'Configure-Service-Mode'.
'General Parameters' tab offers a different list for
storage engines as the table editor 'table options' tab.
This is similar to bug #26589

MySQL Administrator 1.2.10

MySQL Server Information
--------------------------------------------------------------------------------
Connected to MySQL Server Instance
  Username:                root
  Hostname:                localhost
  Port:                    3306
--------------------------------------------------------------------------------
Server Information
  MySQL Version:           MySQL 5.0.27-community-nt via TCP/IP
  Network Name:            localhost
  IP:                      127.0.0.1
--------------------------------------------------------------------------------
Client Information
  Version:                 MySQL Client Version 5.1.11
  Network Name:            xxxxxxxxxx
  IP:                      xxxxxxxxxx
  Operating System:        Windows XP
  Hardware:                2x Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz, 2.0 GB RAM

How to repeat:
Start English or German MySQL Administrator 1.2.9

Open MA in the 'Configure-Service-Mode'
in the 'General Parameters' tab offers a different list for
storage engines as the table editor 'table options' tab.
See screen shot e1.

MyIsam
InooDB
Falcon
BDB
Heap

Now select end edit a table from any database using MA
Activate the 'Table Options' tab and have 
a look at the list of valid table engines.

MyISAM
MEMORY
InnoDB
Archive
MRG_MYISAM

Suggested fix:
have just one piece of code to detect supported
storage engine on current platform and server version.
[6 Mar 2007 16:03] Heinz Schweitzer
e1

Attachment: ScreenHunter_004.jpg (image/jpeg, text), 148.92 KiB.

[6 Mar 2007 18:31] Miguel Solorzano
Thank you for the bug report.
[14 May 2009 12:46] Susanne Ebrecht
Unfortunately this is not a bug.

Because there is none database connection already existing to check which storage engines are supported from the mysql version this inconsistence happens and can't be fixed.