Bug #26757 table creator: discard changes on not existing table doesnt work
Submitted: 1 Mar 2007 17:16 Modified: 5 Feb 2009 10:19
Reporter: Martin Friebe (Gold Quality Contributor) (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.9 OS:Microsoft Windows (Windows XP)
Assigned to: Mike Lischke
Tags: qc

[1 Mar 2007 17:16] Martin Friebe
Description:
Go to "create table" in either the administrator, Query Browser.

you will have an empty form, the table name should be "New Table".

It is necessary that you db does not yet contain a table called "New Table"

Enter any details into the Table creator form.
(It is enough to just edit the comment, but more can be filled in)

Press discard changes, and confirm "yes".

An error is displayed:
"Can not fetch table information"

This error could be ok, if you where editing an existing table, and wanted  to go back to the original table information.

But while creating a new table, "discard" should empty the form. There is no need to reload a table, that does not exist

How to repeat:
see above

Suggested fix:
If creating a new table, discard should empty the form.

Discard may perform a check, if the table "New Table" still is a new table, and warn you, if it has come into existence. 

But it should not fail because a tbale that was never there still doesn't exist.
[1 Mar 2007 17:27] Martin Friebe
Forgot to mention, when you get this error the from is not emptied neither, so you can not just start with a new empty table
[1 Mar 2007 17:58] Miguel Solorzano
Thank you for the bug report.
[6 Mar 2007 5:28] Valerii Kravchuk
Bug #26854 is a duplicate of this one.
[5 Feb 2009 10:19] Mike Lischke
Fixed in repository common, revision 716