Bug #26737 MS Access 2003 Trying to Link to a View in MySQL 5.0.27(NT) causes error -7729
Submitted: 28 Feb 2007 22:16 Modified: 26 Oct 2007 10:35
Reporter: Jim Baker Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.00.11 beta win32 OS:Microsoft Windows (Windows 2000)
Assigned to: CPU Architecture:Any
Tags: access, link, VIEW

[28 Feb 2007 22:16] Jim Baker
Description:
I created both System DSN and File DSNs to see if the results were different, but they weren't.

When I connect to a MySQL database on our server (another Win 2000 box) and try to link to a view, I get this Microsoft Access error: 
"Reserved error (-7729); there is no message for this error."

It doesn't break on all views, but the only view that doesn't cause an error has a single return column. 

It doesn't seem to make a difference whether the "sql_no_cache" directive is used or not.

How to repeat:
Open Access
link to a database
select a view
[1 Mar 2007 11:08] Jess Balint
Can you show the DDL for your view and the tables its based on?
[2 Apr 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[10 Apr 2007 18:05] Valeriy Kravchuk
Feedback is still needed.
[10 May 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[26 Oct 2007 10:35] Susanne Ebrecht
Hi,

unfortunately, we never got feedback, that we needed to analyze this problem.

I'll close this bug now. When you still have this problems, feel free to open it again.

Thank you for trusting MySQL.

Please try our new version MyODBC 5.1.

Kind Regards,

Susanne