Bug #26708 Keywords(auto_increment, default) appear lower case
Submitted: 28 Feb 2007 1:57 Modified: 7 Mar 2007 9:15
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Backup Severity:S3 (Non-critical)
Version:5.0.27 OS:Microsoft Windows (WinXP)
Assigned to: CPU Architecture:Any
Tags: Backup, case, LOWER, qc

[28 Feb 2007 1:57] Jared S
Description:
When backing up a database from 5.0.27 the exported SQL text displays the 'auto_increment' and 'default' keywords from the table structure in lower case.

How to repeat:
1. Run following
2. Backup following from Admin 1.2.9

CREATE DATABASE IF NOT EXISTS test;
USE test;

--
-- Definition of table `new table`
--

DROP TABLE IF EXISTS `new table`;
CREATE TABLE `new table` (
  `id` int(10) unsigned NOT NULL AUTO_INCREMENT,
  `description` varchar(45) NOT NULL DEFAULT 'hi there',
  PRIMARY KEY  (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1;
[28 Feb 2007 9:21] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

See documentation of MySQL Administrator at http://dev.mysql.com/doc/administrator/en/mysql-administrator-backup-introduction.html and mysqldump at http://dev.mysql.com/doc/refman/5.0/en/mysqldump.html
[4 Mar 2007 22:55] Jared S
I dont need MySQL 5.0 and 5.1 producing different backup files on same DB.  Are you saying that you will not even let this bug goto the next step.
[5 Mar 2007 8:13] Sveta Smirnova
Thank you for the additional comment.

Strictly say this behaviour has changed in MySQL 5.1.

Please provide example when this change can broke something.
[5 Mar 2007 22:18] Jared S
I dont care that much cause is small issue and 5.0 will eventually be replaced by 5.1.  I find that when comparing files it can bring up unecessary differences.

Anyway, feel free to close again, you should now have anough feedback to make decision.
[7 Mar 2007 9:15] Sveta Smirnova
Thank you for the comment.

Closed as "Not a bug" again.