Bug #26385 Agent inst - installing to "C:\Program Files (x86)\.." causes agent to not start
Submitted: 14 Feb 2007 23:08 Modified: 15 Feb 2007 16:40
Reporter: Bill Weber Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S2 (Serious)
Version:1.0.1.4391 OS:Microsoft Windows (Windows)
Assigned to: BitRock Merlin CPU Architecture:Any

[14 Feb 2007 23:08] Bill Weber
Description:
If you install the agent to "C:\Program Files (x86)\MySQL\Network\Agent", it will put a line such as "C:\Program Files (x86)\MySQL\Network\Agent/mysql-service-agent.exe --print-uuid ..." in the agent ini file which causes an error when starting the agent. This directory is the default when installing on 64 bit Windows, although it will also occur in 32 bit Windows if you use the same installation directory.

How to repeat:
see above
[14 Feb 2007 23:44] BitRock Merlin
Ouch. This was a bug in InstallBuilder, it is corrected now and new version sent to Keith. Thanks for bringing this to our attention
[15 Feb 2007 2:36] Keith Russell
Reported as fixed in ver => 1.1.0.4773
[15 Feb 2007 16:40] Carsten Segieth
tested OK with 1.1.0.4773 on vista-64-a. I installed in standard path (which is the one shown in the bug report).
[23 Jul 2007 15:04] Laveshan Annamalai
Hi, Im a tech responsible for support of my companies software product. Our software ships with sql. I have vista x64 installed. When i install my instance of msde it puts it in the program files x86 folder. I understand that that is the folder for 32bit apps. The problem i have is that i cannot configure the ports that my sql instances use. We normally use the svrnetcn app to check what port numbers the instances are using. but when i go to that app there are no instances listed there. also when i start the service manager it runs in my sys tray. but when i maximise it there are no instances listed there. This is a problem because i cant check if the sql instance are running or not. Also i cannot point my program to the correct instance successfully as i dont know what port numbers they use. I also have one more question.. Can i install sql to the program files folder? The problem is that i dont have write access for the program files x86 folder.

Thank you, any help would be much appreciated. 
Laveshan Annamalai