Bug #26319 The connection to the target database could not be established (error: 0).
Submitted: 13 Feb 2007 13:10 Modified: 30 Apr 2007 9:21
Reporter: Christoph Moebus Email Updates:
Status: Closed Impact on me:
Category:MySQL Migration Toolkit Severity:S2 (Serious)
Version:1.1.9/1.1.10 OS:Any (Server 2003 Enterprise Edition)
Assigned to: CPU Architecture:Any

[13 Feb 2007 13:10] Christoph Moebus
The following error is reported, when trying to connect to the target database system:
The connection to the target database could not be established (error: 0).
ReverseEngineeringMysqlJdbc.getVersion :Illegal group reference
java.util.regex.Matcher.appendReplacement(Unknown Source)
java.util.regex.Matcher.replaceAll(Unknown Source)
java.lang.String.replaceAll(Unknown Source)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
java.lang.reflect.Method.invoke(Unknown Source)
com.mysql.grt.Grt.callModuleFunction(Unknown Source)

How to repeat:
Selecting the following option during the migration:
1.:-Direct migration
2.:- Source Database: MS Access, driver=access, database with password
3.:- Target Database: MySQL Server, Connection: hostname, port and correct password
4.:- Connecting to servers: the above error occurs, when testing conncetion to target database
[13 Feb 2007 14:46] Valeriy Kravchuk
Thank you for a problem report. What exact version of MySQL server are you using as target?
[13 Feb 2007 14:54] Christoph Moebus
I am using MySQL Version: 5.0.27-community-nt
[19 Feb 2007 15:06] MySQL Verification Team
Thank you for the bug report. Could you please provide a sample .mdb
file which allows to repeat the behavior reported. Thanks in advance.
[19 Feb 2007 15:59] Christoph Moebus
I have added a Test-MS Access Database as Miguel Solorzano wanted
[19 Feb 2007 16:30] MySQL Verification Team
Thank you for the feedback. I was not able to repeat the connection issue
instead I got some errors in the creation result like the below index name:

DROP TABLE IF EXISTS `db_mysql`.`tbl_ma_verrechnungssatz`;
CREATE TABLE `db_mysql`.`tbl_ma_verrechnungssatz` (
  INDEX `{475BCC65-9231-45B8-ABC1-16E627575E1C}` (`ma_qualifikation_id`),

How just now I don't have Access installed I can't verify why that
index name is created in the script. Do you have index names as the above?

Thanks in advance.
[1 Mar 2007 9:32] Christoph Moebus
I have index names like 'ma_qualifikation_id' or so, but no index names like '475BCC65-9231-45B8-ABC1-16E627575E1C'.

Which version of java do you use, because I wonder whether it has something to do with the java version that is installed.
I have tried it again on a different PC (Windows XP Prof.), but the same error occurs (with the same details giving reference to java...)
On both PC's I use the actual Java release 1.5.0 build 11.
[3 Apr 2007 22:59] MySQL Verification Team
Migration Toolkit errors

Attachment: mtoolkit.png (image/x-png, text), 32.33 KiB.

[3 Apr 2007 23:01] MySQL Verification Team
Thank you for the bug report. I still have the same error as before
when creating the table indices (Attached a picture).
[4 Apr 2007 7:29] Christoph Moebus
Hello Miguel,
I don't know how Access names the index internally, but they can not be "" like the MySQL Migration Toolkit shows in the submitted picture, because then Access would not be able to find this index either.

For example in the table "tbl_ma_arbeitszeitmodell" there are two fields that have an index: "ma_arbeitszeitmodell_id" and "ma_id".

I hope this helps. If you need the names of the fields that have an index for the other tables please tell me.
[30 Apr 2007 9:21] Michael G. Zinner
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at


I have now switched to a much simpler string replace function that fixes this problem.