Bug #26113 "MySQL Server 5.0" shortcut does not work when not installed in default location
Submitted: 6 Feb 2007 12:13 Modified: 3 Dec 2008 17:46
Reporter: David Newcomb (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.0.27 OS:Microsoft Windows (Win2K)
Assigned to: Iggy Galarza CPU Architecture:Any

[6 Feb 2007 12:13] David Newcomb
Description:
"MySQL Server 5.0" shortcut does not work when not installed in default location.

To silently install I use:

msiexec.exe /passive /qn /lvx+ c:\Data\MySQL_Installer.log /i mysql-essential-5.0.27-win32.msi INSTALLDIR=C:\Data\MySQL

The installer sets up a shortcut to Programs->MySQL->"MySQL Command Line Client".
When you click on the link a dos box flashes up and then dispears.

This worked in version 4.1 when it was installed in the default location.

How to repeat:
Install into c:\data\MySQL and click shortcut named "MySQL Command Line Client"

Suggested fix:
Change shortcut to:

  mysql -ulocalhost -p mysql

or make the shortcut run the proper file.
[7 Feb 2007 17:31] MySQL Verification Team
Thank you for the bug report.
[3 Dec 2008 17:46] Iggy Galarza
I was able to reproduce the symptom as described but there is no problem with the shortcut. The problem is that after issuing the silent install command, there is no server configured or running. To correct this problem, use the Instance Configuration Wizard silently to configure and start a server.  For example I used these commands:

1. msiexec.exe /passive /qn /lvx+ c:\Data\MySQL_Installer.log /i mysql-essential-5.0.67-win32.msi INSTALLDIR=C:\Data\MySQL
2. cd C:\Data\MySQL\bin\
3. MySQLInstanceConfig.exe -i -q "-nMySQL Server 5.0" -pC:\Data\MySQL -v5.0.67 -lC:\Data\mysql_config.log ServiceName=MySQL50 AddBinToPath=no
ServerType=DEVELOPMENT DatabaseType=MIXED ConnectionUsage=DSS Charset=utf8
SkipNetworking=no Port=3306 RootPassword=root

and the default shortcut worked as expected.