Bug #25964 In place editing fails when data font size < 8
Submitted: 31 Jan 2007 5:19 Modified: 22 Feb 2007 11:59
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.2.9 OS:Microsoft Windows (WinXP)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: Edit, query browser, results, varchar

[31 Jan 2007 5:19] Jared S
Description:
Hi, here is major bug with editing varchar fields from result pane.  The existing test is not displayed afer F2 or double click on field is executed.

How to repeat:
-- 1. Create table

CREATE TABLE `test`.`New Table` (
  `id` INTEGER UNSIGNED NOT NULL AUTO_INCREMENT,
  `description` VARCHAR(45) NOT NULL,
  PRIMARY KEY (`id`)
)
ENGINE = InnoDB;

-- 2. Insert 1 field with description of 'some text'
-- 3. SELECT * FROM `new table`
-- 4. Try to edit the description

-- RESULT : The existing text is not displayed
[31 Jan 2007 5:21] Jared S
CORRECTION: all field types are effected by this bug
[31 Jan 2007 11:28] MySQL Verification Team
Thank you for the bug report. I was unable to repeat the behavior reported
Could you please provide a screenshot showing that behavior?. Thanks in
advance.
[31 Jan 2007 22:00] Jared S
Hi, I have marked as S1, cause I know that Mike has changed font size to default of 7, and this would appear to cripple in-place-editing.

ATTCH: couple of pics that should make reproducing problem easier.
[31 Jan 2007 22:02] Jared S
Shows options I have used

Attachment: font_options.PNG (image/x-png, text), 41.06 KiB.

[31 Jan 2007 22:02] Jared S
Shows editing problem I am having

Attachment: editing_problem.PNG (image/x-png, text), 99.96 KiB.

[6 Feb 2007 11:00] Sveta Smirnova
Jared,

after you click "Apply" button can you see just edited text?
[6 Feb 2007 21:43] Jared S
Huh? you mean edit a cell in results pane and the downsize data font to 7 and click apply.  Yes - I can see the text but at previous font size.

Straight forward bug - In-Place-Editing fails when data font is less then 8 pointas.  

I will rename the bug again.
[8 Feb 2007 8:14] Sveta Smirnova
No,

I mean next sequence of actions:

1. Set new font size.
2. Click "Edit"
3. Enter new text into the field
4. Click "Apply Changes"
[12 Feb 2007 21:55] Jared S
Yes, the steps you have shown should produce a bug.  Let me make them even clearer.

0. Set data font to default of 8 size
1. Load table of your choice to result pane
2. Set data font size to 7 and apply and close
3. Click edit
4. Double click field *it will need to have text in it* and no text will be displayed.

Just about time to get the video capture program out and send you recording of bug ;)
[13 Feb 2007 7:38] Sveta Smirnova
But when I click "Apply changes", I can see text (modified) in the field again. Same on your side? Or you can not?
[13 Feb 2007 10:32] Jared S
No, I can not see text when editing field, please see.. http://bugs.mysql.com/file.php?id=5534

I am using 1.2.9 and font is 'ms sans serif' 6.8.  Maybe verify that data font is set exactly same.

Maybe clear type or some other OS independent setting is making it work on your machine.  

Have you another windows machine?
[13 Feb 2007 10:41] Sveta Smirnova
On the screenshot I see you didn't click "Apply changes" button yet.

Font settings I used when tested were same as in early provided screenshot. I'm not sure about clear type settings: will check.
[13 Feb 2007 12:56] Sveta Smirnova
Tried with different Clear Type settings. Same result. Is your Windows localized? If yes, what is the language?
[13 Feb 2007 21:02] Jared S
Here is my regional settings you need

Attachment: regional.bmp (image/bmp, text), 194.69 KiB.

[14 Feb 2007 10:34] MySQL Verification Team
I also couldn't repeat using mysql-gui-tools-noinstall-5.0-r9a-win32
and 6.8pt fonts as shown.  The text in the row being edited shows up fine.

I am using the windows classic theme of XP 64-bit.
[14 Feb 2007 10:48] Sveta Smirnova
Thank you for the all comments. But seems we can not repeat described behaviour.

Although we can not repeat this bug as described, when I try to edit field with these settings, letters expires until I click "Apply changes button". This should be fixed anyway. It is why I set it as "Verified".

Severity decreased.
[22 Feb 2007 11:59] Mike Lischke
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://dev.mysql.com/doc/en/installing-source.html