Bug #25749 MySQL Administrator/Options/Mac OS X Bug
Submitted: 22 Jan 2007 11:40 Modified: 22 Feb 2007 17:05
Reporter: Lance Bland Email Updates:
Status: Closed Impact on me:
Category:MySQL Administrator Severity:S1 (Critical)
Version:5.0r9 OS:MacOS (Mac OS X v10.4.8)
Assigned to: Alfredo Kojima CPU Architecture:Any

[22 Jan 2007 11:40] Lance Bland
MySQL Administrator version 5.0r8 and 5.0r9 on Mac OS X v10.4.8. Launch MySQL Administrator, click "Options" at top of window and get this in system Console:

2007-01-22 06:07:10.957 MySQL Administrator[25528] *** -[NSCFArray insertObject:atIndex:]: attempt to insert nil

and the MySQL Administrator window does not show the options UI controls.

It worked with 5.0r7, but not since 5.0r8. So, all the options are not available for use.

How to repeat:
See above

Suggested fix:
Need to fix the code. Maybe one of your IB outlets is not assigned.

User Workaround: Rollback to 5.0r7 if one can stand doing that (Too many bugs in the MySQL Query Browser in that version).
[22 Jan 2007 13:48] Lance Bland
Added OS type field since it is probably specific to Mac OS X programming and not Windows.
[26 Jan 2007 8:58] Sveta Smirnova
Thank you for the report.

Verified as described.
[11 Feb 2007 15:20] Peter Wolanin
I'm seeing the same thing with 1.2.9ga (a.k.a 5.0r9).

If I delete /etc/my.cnf Administrator will create the file and let me edit it, but only the first time I run Administrator (also, the screen starts going to garbage after selecting a few different drop-downs).
[22 Feb 2007 17:05] Alfredo Kojima
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at