Bug #25689 mysql-max-nt crash
Submitted: 18 Jan 2007 7:17 Modified: 14 May 2007 10:11
Reporter: Sedat Onur ORAKOGLU Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.27-community-max-nt OS:Microsoft Windows (win2003 server)
Assigned to: CPU Architecture:Any
Tags: crash

[18 Jan 2007 7:17] Sedat Onur ORAKOGLU
Description:
Faulting application mysqld-max-nt.exe, version 0.0.0.0, faulting module mysqld-max-nt.exe, version 0.0.0.0, fault address 0x00014990.

in windows events viewers/application section i get this message and mysql stops

at the same time in system section 

The ModMysql service terminated unexpectedly.  It has done this 5 time(s).

do you have any idea about this ?

thanks.

How to repeat:
2 or 3 times a week
[18 Jan 2007 13:42] Valeriy Kravchuk
Thank you for a problem report. Please, send your my.ini file content, describe your hardware (how much RAM do you have, is it 64-bit) and send/upload your MySQL error log (usually it is <hostname>.err file in the data directory).
[18 Jan 2007 18:24] Sedat Onur ORAKOGLU
here is my.ini content ;

[ModMysql]
basedir="f:/mod/"
datadir="f:/mod/data/"
port=3310
skip-locking
skip-bdb
skip-innodb
#init_connect='SET NAMES LATIN5'
join_buffer_size=8M
key_buffer_size=512M
max_allowed_packet = 3M
myisam_sort_buffer_size = 64M
query_cache_size= 32M
read_buffer_size = 2M
read_rnd_buffer_size = 16M
sort_buffer_size = 16M
table_cache = 512
thread_cache = 8

#shared_memory
myisam_max_sort_file_size=100G
myisam_max_extra_sort_file_size=100G
default-character-set=latin5

####

the properties of the server is ;

IBM e-Server 226
4 X Intel Xeon 3.00 GHZ CPUs
4GB of Ram

i added the server.err file to files section

thanks.
[18 Jan 2007 18:25] Sedat Onur ORAKOGLU
the .err file

Attachment: server.err (application/octet-stream, text), 5.94 KiB.

[12 Feb 2007 18:16] Valeriy Kravchuk
I had found several messages like:

070105  3:37:48 [ERROR] Out of memory; check if mysqld or some other process uses all available memory; if not, you may have to use 'ulimit' to allow mysqld to use more memory or you can add more swap space

in your error log. So, it looks like simple out of memory issue (and not a bug). What is the usual amount of Available Physical Memory on your system, according to Task Manager?

Please, try to set:

join_buffer_size=2M
key_buffer_size=512M
max_allowed_packet = 3M
myisam_sort_buffer_size = 8M
query_cache_size= 32M
read_buffer_size = 1M
read_rnd_buffer_size = 1M
sort_buffer_size = 1M

in your my.ini, restart MySQL server and check will it have any impact on crashing.
[13 Feb 2007 10:25] Sedat Onur ORAKOGLU
thanks for suggestion.

the server didn't crash in last 6 days.

but there are some new messages that i can't understand :
   'Aborted connection 19 to db ....'.

i added '## SERVER CRAHSED' into the .err log where the server stops
and i sent the last my.ini file.
[13 Feb 2007 10:26] Sedat Onur ORAKOGLU
the .err file

Attachment: orca-c-altindag.err (application/octet-stream, text), 108.16 KiB.

[13 Feb 2007 10:27] Sedat Onur ORAKOGLU
the last .ini file

Attachment: my.ini (application/octet-stream, text), 554 bytes.

[12 Mar 2007 11:08] Valeriy Kravchuk
Please, try to use newer version, 5.0.37, and check if you will get any similar crashes.
[12 Apr 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[13 Apr 2007 4:55] Valeriy Kravchuk
Feedback is still needed.
[13 May 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[14 May 2007 10:11] Sedat Onur ORAKOGLU
with version 5.0.37 crash problem solved.
thanks;