Bug #25653 creating referential constraints fails randomly
Submitted: 16 Jan 2007 16:10 Modified: 16 Jan 2007 16:30
Reporter: Axel Schwenke Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.0.36-bk OS:Linux (Linux)
Assigned to: Assigned Account CPU Architecture:Any

[16 Jan 2007 16:10] Axel Schwenke
Description:
Creating a bunch of InnoDB tables with referential constraints fails - but only sometimes and for varying constraints - with errno 150. The provided DDL looks OK.

The problem was found by a customer using a pre-release custom build of 5.0.30-enterprise on Windows XP. I was able to reproduce it with 5.0.34-bk and latest 5.0.36-bk on Linux 2.6.15 (x86). 5.1 seems not to be affected (tried with 5.1.15-bk). 4.1 is not affected according to customer.

How to repeat:
using the attached file test.ddl:

while true; do ( mysql <test.ddl || mysql -e "SHOW INNODB STATUS" ) >> log; done
[16 Jan 2007 16:15] Shane Bester
i got crash about 1 in 5 tries in various statements on windows. attached a stack trace

Attachment: bug25653_5.0.34_windows.txt (text/plain), 3.51 KiB.

[16 Jan 2007 16:22] Heikki Tuuri
This may be a duplicate of http://bugs.mysql.com/bug.php?id=25596

Something was broken in 5.0.3x.
[16 Jan 2007 16:28] Axel Schwenke
I had a crash on Linux now. Raising severity.
[16 Jan 2007 16:30] Axel Schwenke
As pointed out by Heikki, this is a duplicate of #25596.
[16 Jan 2007 16:39] Shawn Green
An update to the server versions involved in this bug: The customer was using version 5.0.30 successfully. The script began to fail only with v5.0.32 or newer.
[16 Jan 2007 18:14] Heikki Tuuri
Bug found. See the duplicate.
[31 Mar 2008 16:36] Tim Small
Hello.  Can you make the test-case file (or an equivalent) mentioned in the original report available to everyone please (or otherwise send me a copy)?  I'd like to use it during testing when preparing a patch for the Debian GNU/Linux 4.0 release.

Regards,

Tim.