Bug #25586 Row format is not showing correctly
Submitted: 12 Jan 2007 14:19 Modified: 18 Jan 2007 15:58
Reporter: adarsh Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Falcon storage engine Severity:S3 (Non-critical)
Version:5.2.0 falcon-alpha-community OS:Microsoft Windows (WinXP with SP2)
Assigned to: CPU Architecture:Any

[12 Jan 2007 14:19] adarsh
Description:
create a table engine = falcon or MyISAM and change the row format.

execute the following querys.

How to repeat:
use test3;
drop table if exists test1;
create table test1 (a int(11));
insert into test1 values('1'),('2');
alter table `test3`.`test1` Engine = Falcon;
show table status from `test3`;
alter table `test3`.`test1`  Engine=InnoDB comment='InnoDB free: 4096 kB' row_format=DYNAMIC;
show table status from `test3`;
  

for InnoDB it is working.
but for MyISAM and Falcon it is showing like this.

but still it is showing old row format in 'Row_format' = 'DYNAMIC' field and in 'Create options' it is showing 'COMPACT';
[18 Jan 2007 15:58] MySQL Verification Team
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

mysql> show table status from test3\G
*************************** 1. row ***************************
           Name: test1
         Engine: Falcon
        Version: 10
     Row_format: Fixed
           Rows: 1000
 Avg_row_length: 0
    Data_length: 10000
Max_data_length: 0
   Index_length: 0
      Data_free: 0
 Auto_increment: NULL
    Create_time: NULL
    Update_time: NULL
     Check_time: NULL
      Collation: latin1_swedish_ci
       Checksum: NULL
 Create_options: 
        Comment: 
1 row in set (0.00 sec)

mysql> alter table test1 add col2 varchar(500);
Query OK, 2 rows affected (0.01 sec)
Records: 2  Duplicates: 0  Warnings: 0

mysql> show table status from test3\G
*************************** 1. row ***************************
           Name: test1
         Engine: Falcon
        Version: 10
     Row_format: Dynamic
           Rows: 1000
 Avg_row_length: 0
    Data_length: 10000
Max_data_length: 0
   Index_length: 0
      Data_free: 0
 Auto_increment: NULL
    Create_time: NULL
    Update_time: NULL
     Check_time: NULL
      Collation: latin1_swedish_ci
       Checksum: NULL
 Create_options: 
        Comment: 
1 row in set (0.00 sec)

mysql>