Bug #2557 create table blabla like b1 fails with replication
Submitted: 29 Jan 2004 8:51 Modified: 6 Feb 2004 10:55
Reporter: Donny Simonton Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:4.1.1 OS:Linux (Linux)
Assigned to: Sinisa Milivojevic CPU Architecture:Any

[29 Jan 2004 8:51] Donny Simonton
Description:
When doing a drop table jimbob, create table jimbob like suzy, the create table works fine on the master server, but never gets in the bin-log so the table never gets recreated on the slave.

How to repeat:
Try it.

Suggested fix:
Allow like commands to go through the binary log.
[29 Jan 2004 12:00] Sinisa Milivojevic
Tried with 4.1.2 and could not repeat it.

Tried several table types:

 ./client/mysqlbinlog /usr/local/var/sinisa-bin.000001 
# at 4
#040129 21:59:53 server id 1  log_pos 4         Start: binlog v 3, server v 4.1.2-alpha-debug-log created 040129 21:59:53 at startup
# at 79
#040129 22:00:23 server id 1  log_pos 79        Query   thread_id=1     exec_time=0     error_code=0
use bug;
SET TIMESTAMP=1075406423;
create table xx (id int);
# at 137
#040129 22:00:27 server id 1  log_pos 137       Query   thread_id=1     exec_time=0     error_code=0
SET TIMESTAMP=1075406427;
drop table xx;
# at 184
#040129 22:00:30 server id 1  log_pos 184       Query   thread_id=1     exec_time=0     error_code=0
SET TIMESTAMP=1075406430;
create table xx (id int);
# at 242
#040129 22:00:34 server id 1  log_pos 242       Query   thread_id=1     exec_time=0     error_code=0
SET TIMESTAMP=1075406434;
drop table xx;

It was also transmitted and executed on the slave as well.
[29 Jan 2004 12:04] Donny Simonton
Not: create table xx (id int);

But this:  create table xx like yy;

It's a new feature in 4.1 maybe 4.1.1.

These tables are not created.
[29 Jan 2004 12:48] Sinisa Milivojevic
You are quite right.

Verified against 4.1.1 and 4.1.2.

Thank you for your bug report.
[31 Jan 2004 10:16] Sinisa Milivojevic
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

Fix will come in 4.1.2
[6 Feb 2004 10:55] Sinisa Milivojevic
A patch is pushed.