Bug #25265 Incorrect update scripts
Submitted: 24 Dec 2006 14:27 Modified: 26 Dec 2006 13:29
Reporter: Javier Ortiz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Preview Severity:S2 (Serious)
Version:1.1.8 Alpha OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[24 Dec 2006 14:27] Javier Ortiz
Description:
Syncronization commands are not created correctly. The following error appears:
file source\myx_grt_value.c: line 3307: assertion `dict != NULL' failed
file source\myx_grt_value.c: line 3307: assertion `dict != NULL' failed
file source\myx_grt_value.c: line 3307: assertion `dict != NULL' failed
file source\myx_grt_value.c: line 3307: assertion `dict != NULL' failed
file source\myx_grt_value.c: line 3307: assertion `dict != NULL' failed
file source\myx_grt_value.c: line 3307: assertion `dict != NULL' failed
file source\myx_grt_value.c: line 3307: assertion `dict != NULL' failed

How to repeat:
See attachment scripts.

Suggested fix:
Correct script generator. Also ability to select the type of engine in the DB.
[24 Dec 2006 14:46] Javier Ortiz
The same error occurs while using the native driver
[26 Dec 2006 10:58] Sveta Smirnova
Thank you for the report.

Please confirm or refuse if this bug is duplicate of bug #18263 and Bug #24881.
[26 Dec 2006 11:44] Javier Ortiz
Revised bug #18263 and Bug #24881 as requested but my case is not a duplicate of those. It might be related somehow. I think the root cause might be the same for all 3 bugs. In my case no Reverse Engineering was performed, I was creaing a DB from scratch but the same might happen if you do a reverse engineering and modify.
[26 Dec 2006 13:22] Sveta Smirnova
Attached sql file created by MySQL Migration Toolkit. You say you didn't perform reverse engineering. Is it surely MySQL Workbench bug? If so describe your actions step-by-step.
[26 Dec 2006 13:27] Javier Ortiz
I'm deeply sorry I mixed bugs. In this case I did reverse engeneering. Being that the case this bug is related to the previously mentioned bugs.
[26 Dec 2006 13:29] Sveta Smirnova
I mark it as duplicate of bug #18263