Bug #25263 Memo/text Updates fail in Access
Submitted: 24 Dec 2006 10:44 Modified: 10 Jul 2007 5:46
Reporter: Ross Ivantsov Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.00.10 OS:Microsoft Windows (Windows XP)
Assigned to: Jess Balint

[24 Dec 2006 10:44] Ross Ivantsov
Description:
The edited record is not saved. An error message appears:

ODBC -- update on a linked table 'table_name' failed.
[MySQL][MyODBC 5.00.10] Function sequence error (#0)

How to repeat:
- uninstall any previous MySQL ODBC through Add/remove programs
- install MySQL ODBC 5.00.10beta
- create ODBC connection through Administrative Tools->ODBC Connection
- create a nerw database in Access 2003
- link tables with cyrillic unicode data from the created ODBC
- open table
- the Cyrillic letters are now displayed corectly (no ???? signs)
- try to edit some cyrillic record
- go to new record

The edited record is not saved. An error message appears:

ODBC -- update on a linked table 'table_name' failed.
[MySQL][MyODBC 5.00.10] Function sequence error (#0)
[24 Dec 2006 10:53] Ross Ivantsov
Message pop-up

Attachment: message.JPG (image/pjpeg, text), 14.32 KiB.

[24 Dec 2006 10:59] Ross Ivantsov
One more thing i noticed - this bug appears when you try to edit ANY record that contains text/memo fields. If the record contains only numeric fields, the edit is successful.
[28 Dec 2006 16:35] Jess Balint
Ross - Thanks for your report. Can you please share your table schema and an ODBC trace log? Thanks!
[28 Dec 2006 21:13] Ross Ivantsov
Faulty table

Attachment: wtmactions.sql (application/octet-stream, text), 2.25 KiB.

[28 Dec 2006 21:15] Ross Ivantsov
>Ross - Thanks for your report. Can you please share your table schema
>and an ODBC trace log? Thanks!

I just attached a .sql that contains the essence of problem. Just create a new database and use this sql to create a table.
When you try to edit records it throws about 3 different errors (function unknown error, general error, sequence error etc..). Just test with Access 2003 (LINKED table).

Will wait for your help.
[14 Jan 2007 16:13] Georgios Nikolaidis
Let me vote for this bug too.

Server is "mysql  Ver 14.12 Distrib 5.0.30, for pc-linux-gnu (i486) using readline 5.2"

Client is Access 2003 through "MySQL Connector/ODBC 5.0"

Utf8 data+collation columns with greek characters are displayed/sorted correctly in Access. Altering any record outputs following message (slighlty different from original submission)

ODBC--update on linked table '<blabla>' failed.
[MySQL][MyODBC 5.00.10] General error (#0) [MySQL][MyODBC 5.00.10] General error (#0)
[29 Jan 2007 19:09] Jess Balint
Changed title. This bug is *totally* unrelated to Unicode handling.
[29 Jan 2007 20:24] Jess Balint
Fixed up SQLParamData/SQLPutData to work well with Access. Committed in rev#778.