Bug #25187 agent inst on Solaris10_x86 hangs in text and in unattended mode
Submitted: 19 Dec 2006 21:49 Modified: 1 Feb 2007 12:10
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
Category:MySQL Enterprise Monitor: Installing Severity:S2 (Serious)
Version: OS:Solaris (Solaris10_x86)
Assigned to: Carsten Segieth CPU Architecture:Any
Tags: network drive, target dir, unattended

[19 Dec 2006 21:49] Carsten Segieth
Running the agent installer on 'sol10-x86' in unattended mode does not work, the installer hangs. Using mode 'text' the installation can be started, but does not accept the parameters given on the command line.

tested installer:
-rwxr-xr-x   1 7443546 Dec 19 18:07 /users/schilders/public_html/official_builds/official/

/users/schilders/public_html/official_builds/official/      ELF 32-bit LSB executabl
e 80386 Version 1, dynamically linked, stripped

MySQL Network Service Agent --- Built on 2006-12-18 19:39:07

MySQL Network Service Agent

 --help                         Display the list of valid options

 --version                      Display product information

 --optionfile <optionfile>      Installation option file

 --mode <mode>                  Installation mode
                                Default: xwindow
                                Allowed: xwindow text unattended

 --debugtrace <debugtrace>      Debug filename

 --installdir <installdir>      Installation directory

 --mysqlhost <mysqlhost>        MySQL hostname or IP address

 --checkmysqlhost <checkmysqlhost> Validate MySQL hostname or IP address
                                Default: yes

 --mysqlport <mysqlport>        MySQL port on
                                Default: 13306

 --mysqluser <mysqluser>        Username on

 --mysqlpassword <mysqlpassword> Password for mysqluser on

 --managerhost <managerhost>    Hostname or IP address

 --tomcatport <tomcatport>      Port on
                                Default: 18080

 --agentuser <agentuser>        Agent username on
                                Default: agent

 --agentpassword <agentpassword> Agent password for agent on

 --servername <servername>      Hostname to display

command line that never returns control:
/users/schilders/public_html/official_builds/official/ --installdir /users/csegieth/mysql/network/agent/ --debugtrace /users/csegieth/mysql/network/agent/ --mysqlhost win2003a-x86 --mysqlport 3307 --mysqluser agent --mysqlpassword mysql --checkmysqlhost yes --managerhost qa-srv-b --tomcatport 18080 --agentuser pinoagent --agentpassword onipagent --servername --mode unattended

command line that starts the installer, but shows the wrong installation dir:
/users/schilders/public_html/official_builds/official/ --installdir /users/csegieth/mysql/network/agent/ --debugtrace /users/csegieth/mysql/network/agent/ --mysqlhost win2003a-x86 --mysqlport 3307 --mysqluser agent --mysqlpassword mysql --checkmysqlhost yes --managerhost qa-srv-b --tomcatport 18080 --agentuser pinoagent --agentpassword onipagent --servername --mode text

How to repeat:
see commands above

Suggested fix:
- make unattended install work
- use all given command line parameters to override the defaults
[19 Dec 2006 22:27] Carsten Segieth
install hangs also in 'text' mode - I could watch this for > 10 min until I killed the process:

Please wait while Setup installs MySQL Network Service Agent on your computer.

 0% ______________ 50% ______________ 100%
[19 Dec 2006 22:36] BitRock Merlin
Can you send us the debug log to support@bitrock.com?

[19 Dec 2006 23:45] Carsten Segieth
log has been sent, but as I have only one log from different tests it might not be exact from a call shown above. I see only 1 log although I used different file names ...

But: the solaris10-x86 installer worked when I used a different dir to install (/tmp/...). But as I used a script for my tests there must be a problem in the installer as the problem did not occur when installing 19 other agents before into this shared network dir (/users/csegieth/...).

So I reduce S/P as the installer works 'in general'.
[20 Dec 2006 0:55] BitRock Merlin
My guess is that the agent is hanging when creating the uuid. Are there any known problems with starting the agents over NFS. What happens if you try to do the following manually?

mysql-service-agent --print-uuid

Was the mysql-service-agent.ini file created?

Can you run the installer through 'truss' and see where it hangs?


[20 Dec 2006 1:05] Carsten Segieth
the Solaris9_x86 installer worked as expected, using the installdir in /users/csegieth/... which is created by my test script. So I don't think it's a path length problem or a general Solaris_x86 problem.
[21 Jan 2007 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[1 Feb 2007 12:10] Carsten Segieth
tested OK: on sol10-x86 monitoring win2003a-x86:3307, reporting to net-qa2:8080, named '', installed 2007-02-01-13.06.34 to '/users/csegieth/mysql/network/agent/', using /users/csegieth/bin/test-agent.sh with mode 'unattended'