Bug #2517 Setting lower_case_table_names=0 causes mysql server to crash on startup.
Submitted: 26 Jan 2004 10:29 Modified: 26 Jan 2004 10:41
Reporter: Christopher Vincelette Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:4.0.17 OS:Microsoft Windows (WindowsXP w/ Service Pack 1)
Assigned to: CPU Architecture:Any

[26 Jan 2004 10:29] Christopher Vincelette
Description:
Starting the mysql server from the command line with the following flag:
lower_case_table_names=0

causes mysql server to crash on startup.

This flag can be set to the number 1 (ON) with no ill effects.

How to repeat:
From a clean install of 4.0.17 open a Command Line window.

cd to the mysql\bin directory

type:
 mysqld lower_case_table_names=0

hit enter.

You should now be greeted by a dialog telling you there was a problem with the application and microsoft would like you to tell them all about it. :P

Suggested fix:
This worked correctly from at least 4.0.13 up to 4.0.16.

The correct code should exist in one of those source trees.
[26 Jan 2004 10:41] Guilhem Bichot
duplicate of BUG#2481 http://bugs.mysql.com/?id=2481
which is fixed in 4.0.18