Bug #2511 installation fails to create all system tables
Submitted: 26 Jan 2004 5:27 Modified: 27 Jan 2004 14:37
Reporter: [ name withheld ] Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.1.1 OS:Linux (linux)
Assigned to: Dean Ellis CPU Architecture:Any

[26 Jan 2004 5:27] [ name withheld ]

When installing the alpha 4.1.1 release on a Linux platform, not all system tables are created properly. Specifically, using either the RPMs or the tarred distribution, the myqsl_install_db script fails when invoking fill_help_tables.sql---so I reckon the problem must be there.

How to repeat:
Start a fresh installation, on a Linux system, of the 4.1.1 release using either the RPMs or the tarred distribution.
[26 Jan 2004 5:31] [ name withheld ]
output of mysql_install_db

Attachment: mysql_install_db.out (application/octet-stream, text), 1.25 KiB.

[27 Jan 2004 14:37] Dean Ellis
I cannot repeat this using our 4.1.1 binary distribution.  The help tables are created and populated successfully.

Which exact file did you try?
[28 Jan 2004 0:00] [ name withheld ]
I first tried the MySQL-server-4.1.1-1.i386.rpm distribution. Here is the output:

> [root@styx root]# rpm -i MySQL-server-4.1.1-1.i386.rpm
> warning: MySQL-server-4.1.1-1.i386.rpm: V3 DSA signature: NOKEY, key ID 
> 5072e1f5
> ERROR: 1064  You have an error in your SQL syntax.  Check the manual that 
> corresponds to your MySQL server version for the right syntax to use near '"   
> BIT_AND(expr)\nReturns the bitwise AND of all bits in expr. The calculation ' 
> at line 1
> 040128  9:57:02  Aborting
> 040128  9:57:02  /usr/sbin/mysqld: Shutdown Complete
> /usr/bin/mysql_install_db: line 274:  7277 Broken pipe             cat 
> $fill_help_tables
> Installation of grant tables failed!
> Examine the logs in /var/lib/mysql for more information.
> You can also try to start the mysqld daemon with:
> /usr/sbin/mysqld --skip-grant &
> You can use the command line tool
> /usr/bin/mysql to connect to the mysql
> database and look at the grant tables:
> shell> /usr/bin/mysql -u root mysql
> mysql> show tables
> Try 'mysqld --help' if you have problems with paths. Using --log
> gives you a log in /var/lib/mysql that may be helpful.
> The latest information about MySQL is available on the web at
> http://www.mysql.com
> Please consult the MySQL manual section: 'Problems running mysql_install_db',
> and the manual section that describes problems on your OS.
> Another information source is the MySQL email archive.
> Please check all of the above before mailing us!
> And if you do mail us, you MUST use the /usr/bin/mysqlbug script!
> Starting mysqld daemon with databases from /var/lib/mysql
> [root@styx root]#

The same happens when using the tarred distribution.
[3 Feb 2004 7:46] Dean Ellis
Check your setting for max_allowed_packet.  If this is too low, you can see problems like this.
[4 Feb 2004 2:20] [ name withheld ]
In a fresh installation, the /etc/my.cnf that is automatically created by the RPM specifies a max_allowed_packet of 1M.

I get the same error when I change it to 5M.
[5 Feb 2004 11:46] Dean Ellis
Are you setting it for both mysqld and the client?
[19 Feb 2004 3:59] [ name withheld ]
I cannot see how I can set the max_allowed_packet client parameter during the RPM installation...
[18 May 2004 11:36] Heinz Bast
I ran into exactly the same problem ( 4.1.1. Alpha, Linux SUSE 9.0 ). After deleting /etc/my.cnf it worked fine immeadiately. 
My old /etc/my.cnf was left from an installation to a different directory, from a different release version etc. I'm not sure what entry in my.cnf caused the trouble but removing the file completely solved the problem