Bug #24941 make install fails, nonexistent directories
Submitted: 10 Dec 2006 7:30 Modified: 19 Dec 2006 16:26
Reporter: Jon Stephens Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.1.15-bk OS:Linux (SuSE 10.0/32-bit, SuSE 10.1/AMD64)
Assigned to: CPU Architecture:Any
Tags: 5.1, compiling, SOURCE

[10 Dec 2006 7:30] Jon Stephens
Fresh bk clone (last changeset was 1.2356 on 2006-12-07) fails to install using compile-pentium-debug-max, complains about non-existent directories.

Relevant output from make install shown here:

/usr/bin/install -c -m 644 ./t/*.imtest /usr/local/mysql/mysql-test/t
/usr/bin/install -c -m 644 ./t/*.sql /usr/local/mysql/mysql-test/t
/usr/bin/install -c -m 644 ./t/*.disabled /usr/local/mysql/mysql-test/t
/usr/bin/install: cannot stat `./t/*.disabled': No such file or directory
make[4]: [install-data-local] Error 1 (ignored)
/usr/bin/install -c -m 644 ./t/*.opt /usr/local/mysql/mysql-test/t
/usr/bin/install -c ./t/*.sh /usr/local/mysql/mysql-test/t
/usr/bin/install -c -m 644 ./t/*.slave-mi /usr/local/mysql/mysql-test/t
/usr/bin/install -c -m 644 ./r/*.result /usr/local/mysql/mysql-test/r
/usr/bin/install -c -m 644 ./r/*.require /usr/local/mysql/mysql-test/r
/usr/bin/install -c -m 644 ./extra/binlog_tests/*.test /usr/local/mysql/mysql-test/extra/binlog_tests
/usr/bin/install -c -m 644 ./extra/rpl_tests/*.test /usr/local/mysql/mysql-test/extra/rpl_tests
/usr/bin/install -c -m 644 ./extra/binlog_tests/*.opt /usr/local/mysql/mysql-test/extra/binlog_tests
/usr/bin/install: cannot stat `./extra/binlog_tests/*.opt': No such file or directory
make[4]: [install-data-local] Error 1 (ignored)
/usr/bin/install -c -m 644 ./extra/rpl_tests/*.opt /usr/local/mysql/mysql-test/extra/rpl_tests
/usr/bin/install: cannot stat `./extra/rpl_tests/*.opt': No such file or directory
make[4]: [install-data-local] Error 1 (ignored)
/usr/bin/install -c -m 644 ./include/*.inc /usr/local/mysql/mysql-test/include
/usr/bin/install -c -m 644 ./include/*.test /usr/local/mysql/mysql-test/include
/usr/bin/install -c -m 644 ./std_data/*.dat /usr/local/mysql/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.*001 /usr/local/mysql/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.cnf /usr/local/mysql/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/des_key_file /usr/local/mysql/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/Moscow_leap /usr/local/mysql/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.pem /usr/local/mysql/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.frm /usr/local/mysql/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.MY* /std_data
/usr/bin/install: target `/std_data' is not a directory
make[4]: *** [install-data-local] Error 1
make[4]: Leaving directory `/home/jon/bk/mysql-5.1/mysql-test'
make[3]: *** [install-am] Error 2
make[3]: Leaving directory `/home/jon/bk/mysql-5.1/mysql-test'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/home/jon/bk/mysql-5.1/mysql-test'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/jon/bk/mysql-5.1'
make: *** [install] Error 2

How to repeat:
Invoke BUILD/compile-pentium-debug-max in root of 5.1 source.

I built as user jon, then ran make install as root, but I don't think this is related to Bug#19738, but rather to some recent changes in tests and possibly sql-bench.

Suggested fix:
Fix errors shown.
[10 Dec 2006 7:36] Jon Stephens
Problem also occurs on 64-bit Linux.

Does not occur with 5.1.14-beta release source on either platform.
[14 Dec 2006 21:34] Valeriy Kravchuk
Thank you for a problem report. Please, try to repeat with a newer 5.1.15-BK (ChangeSet@1.2358, 2006-12-12 18:01:44+04:00 is the latest for me now), and inform about the results.
[15 Dec 2006 3:07] Jon Stephens
Tried with fresh pull, latest rev. 1.2358, same result, even after deleting /usr/local/mysql and everything in it and running compile-pentium-debug-max again.

I also noticed errors during make about missing file sql-bench/Makefile.in.

Haven't tested again on 64-bit, but this happens on both SuSE 10.0 & 10.1 32-bit.
[15 Dec 2006 5:56] Valeriy Kravchuk
Verified just as described.
[19 Dec 2006 16:26] Jon Stephens
This bug appears to have been fixed by the same patch that fixed Bug#24902, so I've marked this one as a duplicate.

Note: I had to re-clone the 5.1 tree after the Bug#24902 patch was pushed, as all files in the sql-bench directory had disappeared, but once I'd done so, the server built normally. This was the case on both my AMD64 and IA32 machines.