Bug #24835 5.0 behavior for char storage listed in the 4.1 docs
Submitted: 5 Dec 2006 19:43 Modified: 6 Dec 2006 3:38
Reporter: Monty Taylor Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version: OS:
Assigned to: Jon Stephens CPU Architecture:Any
Triage: D4 (Minor)

[5 Dec 2006 19:43] Monty Taylor
Description:
In the 4.1 docs, the page http://dev.mysql.com/doc/refman/4.1/en/charset-unicode.html says this:

"Otherwise, MySQL must reserve three bytes for each character in a CHAR CHARACTER SET utf8 column because that is the maximum possible length. For example, MySQL must reserve 30 bytes for a CHAR(10) CHARACTER SET utf8 column." 

That's the behavior in 5.0, though. In 4.1, character widths are stored in units of bytes, not characters, so you actually get 3 characters of storage in a char(10) character set utf8 column. 

How to repeat:
Just look on the doc page. :)

Suggested fix:
The tip isn't so valid itself, but it may want to be replaced with a warning about storage size possibly being smaller than expected.
[5 Dec 2006 20:00] Paul Dubois
The behavior is the same in 4.1. See first bullet on this page:

http://dev.mysql.com/doc/refman/4.1/en/string-type-overview.html
[6 Dec 2006 3:38] Stefan Hinz
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php