Bug #24824 Changes to startup variables corrupts the configuration file
Submitted: 5 Dec 2006 15:10 Modified: 7 Dec 2006 10:46
Reporter: Anthony Marston Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S1 (Critical)
Version:1.2.6 OS:Microsoft Windows (Windows XP)
Assigned to: Mike Lischke CPU Architecture:Any

[5 Dec 2006 15:10] Anthony Marston
Description:
Using MySQL version 5.0.27

If I use MySQL Administrator to alter a startup variable, for example on the "Advanced" tab set "Use ANSI SQL" to ON, then start and stop the service, I find that the configuration file has been corrupted. I can no longer access any of my INNODB tables, and if I stop and restart MySQL Administrator I get the following message:

Either the server service or the configuration file could not be found. Startup variables and service section are therefore disabled.

When I look in my config file (F:\MySQL\MySQL Server 5.0\my.ini) I see that in the [mysqld] section that the "ansi" option has been inserted, but all the other options have been commented out. I have to reinstate them manually before I can continue.

How to repeat:
Change one of the startup variables, stop and start the service, restart MySQL Administrator, attempt to view any INNODB tables.

Suggested fix:
Don't comment out any of the options which have been set.
[6 Dec 2006 10:25] Miguel Solorzano
Thank you for the bug report. I was able to repeat.
[6 Dec 2006 10:34] Sveta Smirnova
Bug #23885 has marked as duplicate of this one.
[7 Dec 2006 9:02] Mike Lischke
Anthony, how many servers have you installed? Which versions, if more than one? Please start MA in service config mode (in the log-in dialog don't click OK, but hold ctrl key and click on the now changed button "Skip"). Go to the service control for this 5.0 server and select tab "Configure Service". 

Now look what value is in the (not editable) "Section Name" field? Then switch to the "Startup Variables" section and look at the bottom of the variables side. There are two values: "Option File" and "Section". What is written there?

Please make a copy of your my.ini file in another folder. Then use MA, button "Choose Option File" to select this file (pick the [mysqld] section. Change the "Wait timeout" value again, save and look into the file. Do you still find all other values commented out?

If yes, restore the my.ini file copy to the good version, use an external editor and change the [mysqld] section name to that of your service, e.g. [mysql50] *unless* it is [mysql] (note the missing "d"!). The [mysql] section is reserved for the command line client.
[7 Dec 2006 10:46] Mike Lischke
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://dev.mysql.com/doc/en/installing-source.html