Bug #24731 Shared memory connections do not work with MySql ran as service on Vista
Submitted: 30 Nov 2006 19:39 Modified: 3 Mar 2008 20:24
Reporter: Reggie Burnett Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0 OS:Microsoft Windows (Vista)
Assigned to: Reggie Burnett CPU Architecture:Any
Tags: Contribution, vista
Triage: D2 (Serious)

[30 Nov 2006 19:39] Reggie Burnett
Description:
Shared memory connections do not work when MySQl is ran as a service on Vista.

How to repeat:
1. Install MySQL as a service on Vista RTM.  
2. Modify my.ini to include shared-memory as an option
2. Start service
3. Attempt to connect to the server using --protocol=memory
[1 Dec 2006 10:58] Sveta Smirnova
Thank you for the report.

But Windows Vista is not supported until it's official release.
[1 Dec 2006 13:40] Reggie Burnett
Vista has been officially released and we are under a time crunch to get MySQL compatible with Vista so moving this bug report back to open.
[6 Dec 2006 7:35] Sveta Smirnova
There is similar bug #24841.

Reporter provided patch.
[6 Dec 2006 7:57] Armin Schöffmann
This bug concerns any version of windows nt, if a connection is made from within a remote-session (terminal services or remote desktop).

Refering to bug-report #24731, the problem is caused by the client and not the server.

I suggest to update the OS-tag. This bug-report is hard to find otherwise.
[6 Dec 2006 7:59] Armin Schöffmann
I meant:
[...] Refering to bug #24841 [...]
[12 Apr 2007 10:16] Sveta Smirnova
Thank you for the report.

Verified as described.
[5 Jun 2007 15:11] Armin Schöffmann
diff-patch: create named kernel-objects for shared-memory-connections in global name-space

Attachment: client.c.patch.txt (text/plain), 1.01 KiB.

[7 Jun 2007 15:33] Reggie Burnett
Pushed in mysql-5.0-maint and 5.1-new-maint team trees
[16 Jun 2007 4:50] Bugs System
Pushed into 5.0.44
[16 Jun 2007 4:51] Bugs System
Pushed into 5.1.20-beta
[28 Feb 2008 17:19] Reggie Burnett
Paul

The issue was that when mysqld is run as a service then the shared memory objects that are created need to be in the global namespace since the server and client are running under different logins.
[3 Mar 2008 20:24] Paul Dubois
Noted in 5.0.44, 5.1.20 changelogs.

When mysqld was run as a Windows service, shared memory objects were
not created in the global namespace and could not be used by clients
to connect.
[17 Jun 2009 19:27] Bugs System
Pushed into 5.4.4-alpha (revid:alik@sun.com-20090616183122-chjzbaa30qopdra9) (version source revid:davi.arnaut@sun.com-20090610142446-5sznm24ozsl95nfn) (merge vers: 5.4.4-alpha) (pib:11)
[26 Aug 2009 13:45] Bugs System
Pushed into 5.1.37-ndb-7.0.8 (revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (version source revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (merge vers: 5.1.37-ndb-7.0.8) (pib:11)
[26 Aug 2009 13:46] Bugs System
Pushed into 5.1.37-ndb-6.3.27 (revid:jonas@mysql.com-20090826105955-bkj027t47gfbamnc) (version source revid:jonas@mysql.com-20090826105955-bkj027t47gfbamnc) (merge vers: 5.1.37-ndb-6.3.27) (pib:11)
[26 Aug 2009 13:48] Bugs System
Pushed into 5.1.37-ndb-6.2.19 (revid:jonas@mysql.com-20090825194404-37rtosk049t9koc4) (version source revid:jonas@mysql.com-20090825194404-37rtosk049t9koc4) (merge vers: 5.1.37-ndb-6.2.19) (pib:11)
[27 Aug 2009 16:32] Bugs System
Pushed into 5.1.35-ndb-7.1.0 (revid:magnus.blaudd@sun.com-20090827163030-6o3kk6r2oua159hr) (version source revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (merge vers: 5.1.37-ndb-7.0.8) (pib:11)