Bug #24677 Can't see tables in CRXI using System DSN
Submitted: 29 Nov 2006 3:26 Modified: 5 Jan 2008 2:50
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.0.9 OS:Microsoft Windows (WinXP)
Assigned to: Jess Balint CPU Architecture:Any
Tags: Connection, crystal, database, ODBC, reports
Triage: D3 (Medium)

[29 Nov 2006 3:26] Jared S
Description:
Hi,

After installing the latest beta 5.0.2 version of ODBC Connector, I can not see any tables listed in the database expert wizard.

How to repeat:
1. Install Crystal Reports X1 Release 2
2. Create a System DSN to a mysql database
2. Create a new report
3. Using wizard try to connect to new System DSN
4. When it is time to select table, none appear

(see my 4 screenshots)
[29 Nov 2006 3:27] Jared S
Screen 0

Attachment: screen0.PNG (image/x-png, text), 27.24 KiB.

[29 Nov 2006 3:28] Jared S
Screen 1

Attachment: screen1.PNG (image/x-png, text), 19.77 KiB.

[29 Nov 2006 3:28] Jared S
Screen 2

Attachment: screen2.PNG (image/x-png, text), 14.87 KiB.

[29 Nov 2006 3:29] Jared S
Screen 3

Attachment: screen3.PNG (image/x-png, text), 28.76 KiB.

[29 Nov 2006 3:30] Valeriy Kravchuk
Thank you for a problem report. Please, try to repeat with a newer version, 5.00.09, and inform about the results.
[29 Nov 2006 3:34] Jared S
Yes I was using 5.0.9.  I have now updated bug cause I got my version wrong.
[29 Nov 2006 8:06] Tonci Grgin
Hi Jared. I'm making this report my priority. I just need one more piece of information: what is the *exact* version of CR you're using (ie CR XI 83...)?
[29 Nov 2006 9:32] Jared S
I am using CRXI R2 with no patches, you may download the verison I am using from here..

http://ftp1.businessobjects.com/webprod/crxi/CR_Server_XIR2.part1.exe
-and you will need to slip stream R2-
http://ftp1.businessobjects.com/webprod/crxi/CR_Server_XIR2.part2.rar

As for build number, I will post in another 12 hours from now when I am back at my work computer.
[29 Nov 2006 13:15] Tonci Grgin
Hi Jared. I was able to verify this problem with CR XI 11.0.0.895. But USER DSN works as expected! Can you please change severity to S2, at least, since convenient workaround exists.

Changing synopsis from "Can't see tables in CRXI R2" to "Can't see tables in CRXI    using System DSN"
[29 Nov 2006 19:13] Jared S
Hi Toni,

change bug to S2, what is the workaround?
[29 Nov 2006 21:31] Jared S
Hi,

crw32.exe = 11.5.3.417

I understand the workaround now, use User DSN instead of System DSN.
[11 May 2007 8:36] Jared S
Trace log with 5.0.11 BETA

Attachment: SQL.LOG (application/octet-stream, text), 57.32 KiB.

[4 Jan 2008 7:27] Jess Balint
Jared,
Thank you for your patience. If you have a chance, please feel free to try this again using a snapshot of MySQL Connector/ODBC 5.1. You can download snapshots at the following url:

http://downloads.mysql.com/snapshots.php

If the problem persists, please respond with a description of the problem and the version/filename of the driver you used.
[4 Jan 2008 10:17] Tonci Grgin
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://dev.mysql.com/doc/en/installing-source.html

Explanation: Jared, testing with mysql-connector-odbc-5.1.2-betar986-win32 I found no problems. Closing as it appears to be working now.

Environment:
 MySQL server 5.0.54BK on WinXP Pro SP2 localhost
 c/ODBC 5.1.2 rev. 986
 CR XI 11.0.0.2269, Standard report wizard, ODBC(RDO) connection
 System DSN, "Don't use set locale()", "Pad CHAR to full length with spaces", "Don't cache results of forward-only cursors" and "Limit column size to signed 32-bit range"
[5 Jan 2008 2:50] Jared S
Thanks > http://bugs.mysql.com/bug.php?id=33700
[10 Jan 2008 8:52] Tonci Grgin
Bug#33700 was marked as duplicate of this report.