Bug #2465 mysqld fail to start up on OS X
Submitted: 20 Jan 2004 23:03 Modified: 25 Feb 2004 5:43
Reporter: Brian Aker Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version: OS:Mac OS X (OS X)
Assigned to: CPU Architecture:Any

[20 Jan 2004 23:03] Brian Aker
Description:
If debug is compiled and test_if_case_insensitive() then when it calls sql_print_error()
VOID(pthread_mutex_lock(&LOCK_error_log));

will return true since LOCK_error_log will have yet to be initialized.

After a second look at it... I 'm not sure having debug enabled or not will make a difference. It will 
still cause the server to abort startup since as I pointed out the lock has yet to be initialized.

How to repeat:
Compile mysql  (just the latest for th 4.0.x tree) and try to startup mysqld. 

FWIW this is how I compile mysql:

C=gcc CFLAGS="-O3 -fno-omit-frame-pointer" CXX=gcc \
CXXFLAGS="-O3 -fno-omit-frame-pointer -felide-constructors \
-fno-exceptions -fno-rtti" ./configure --prefix=/Users/brian/mysql-compess \
--with-extra-charsets=complex --enable-thread-safe-client \
--enable-local-infile --disable-shared --with-debug
[29 Jan 2004 8:06] Guilhem Bichot
Isn't it 
BUG#2481 "mysqld crash if started with lower-case-table-names=0 and filesystem case-insen"
which is fixed since Dec 30th ?
At least the mutex stuff looks the same.
[25 Feb 2004 5:43] Brian Aker
I confirmed, this was fixed.