Bug #24622 mysql query browser running over an X ssh tunnel fails (as do the other gui tool
Submitted: 27 Nov 2006 14:15 Modified: 16 Jan 2007 9:42
Reporter: Jim OLeary Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:mysql-gui-tools-5.0r6-fc5-i386.tar.gz OS:Linux (Fedora Core 5)
Assigned to: Alfredo Kojima CPU Architecture:Any
Tags: X ssh tunnel

[27 Nov 2006 14:15] Jim OLeary
Description:
connect to the remove host using 'ssh -X user@host'
running  'mysql-query-browser' results in the following error
The program 'mysql-query-browser' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 66 error_code 3 request_code 38 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

The client machine is cygwin, uname -a gives
CYGWIN_NT-5.1 jim 1.5.17(0.129/4/2) 2005-05-25 19:38 i686 unknown unknown Cygwin

ssh -v gives
OpenSSH_4.1p1, OpenSSL 0.9.7g 11 Apr 2005

The linux machine uname -a gives
Linux XXXXXXXX 2.6.18-1.2200.fc5smp #1 SMP Sat Oct 14 17:15:35 EDT 2006 i686 i686 i386 GNU/Linux

How to repeat:
start x on the cygwin machne using 
'startxwin.sh'
connect to the linux machine using
'ssh -X user@host'

try to start the query browser using 
mysql-query-browser
[27 Nov 2006 16:18] Miguel Solorzano
Thank you for the bug report. Indeed I was able to repeat and able to run
other GUI like KWrite in the same way.

miguel@hegel:~> mysql-query-browser
The program 'mysql-query-browser' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 94 error_code 3 request_code 38 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
miguel@hegel:~> ICE default IO error handler doing an exit(), pid = 6295, errno = 0
[15 Jan 2007 19:11] Alfredo Kojima
This seems to be a problem with Gtk. Not only I cannot reproduce it consistently
with QB, but I can also non-consistently repeat the same error using gnome-terminal:

kojima@woodstock:~/svn/mysql-query-browser/source/linux$ gnome-terminal
The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAtom (invalid Atom parameter)'.
  (Details: serial 75 error_code 5 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Thus I'm closing this as Not a Bug.
[16 Jan 2007 9:42] Jim OLeary
found a workaround for the problem. use ssh -Y (instead of ssh -X)