Bug #2427 "Can't create interrupt-thread" on IA64
Submitted: 16 Jan 2004 8:36 Modified: 3 Feb 2004 12:18
Reporter: Lenz Grimmer Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.0.16 OS:Linux (Linux/ia64)
Assigned to: Jani Tolonen CPU Architecture:Any

[16 Jan 2004 8:36] Lenz Grimmer
Forwarded to us via the packagers mailing list - the orignal bug report 
is at 
[after trying to install the package and running mysql_install_db] 
        # cat /var/log/mysql/mysql.err 
        Preparing db table 
        Preparing host table 
        Preparing user table 
        Preparing func table 
        Preparing tables_priv table 
        Preparing columns_priv table 
        Installing all prepared tables 
        040108 14:53:19  Can't create interrupt-thread (error 22, errno: 0) 
        Installation of grant tables failed! 
"perror 22" on our IA64 box gives me "Invalid argument" 

How to repeat:
[16 Jan 2004 9:34] Christian Hammers
MySQL was compiled with the GCC from Debian unstable which was probably version 3.3.3.
[3 Feb 2004 12:18] Sergei Golubchik
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at

Additional info:

see bug#2599