Bug #24217 View in a mysql shows incorrect data.
Submitted: 11 Nov 2006 19:58 Modified: 14 Nov 2006 12:32
Reporter: Chaitanya Kulkarni Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.12 OS:Microsoft Windows (Windows XP SP 2)
Assigned to: CPU Architecture:Any

[11 Nov 2006 19:58] Chaitanya Kulkarni
Description:
When a view is created for data from two tables and linked that table in MS Access. Then the same SQL statement returns correct results from Query Browser or Navicat, but shows incorrect data for that view and also incorrect no. of recods for that database. This problem happens only in MySQL.Why?

How to repeat:
1) create tow tables and link them using a relationship beteen them
2)create a view based on these two tables and save it. Then link the data toMS Access as a linked table.and open it. It shows incorrect data for that query.

Suggested fix:
--
[14 Nov 2006 12:32] Tonci Grgin
Hi C.K. Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Explanation: This is the duplicate of Bug#22014 and/or Bug#23122. It looks like it's very MS Access version dependant since I can't repeat it. Please search bug reports regarding downgrade of JET engine.