Bug #24185 MaAS embedded MySQL server has problems starting on AMD X86_64 RedHat ES4
Submitted: 10 Nov 2006 13:08 Modified: 13 Apr 2007 13:06
Reporter: Anders Karlsson Email Updates:
Status: Closed Impact on me:
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version:1.0.0 OS:Linux (RedHat ES4)
Assigned to: BitRock Merlin CPU Architecture:Any
Tags: mer101

[10 Nov 2006 13:08] Anders Karlsson
Installing this on a RHES4 fails. The embedded MySQL server fails with
Signal 6 after a
"libgcc_s.so.1 must be installed for pthread_cancel"

Exact dump is:
Installing 0% ______________ 50% ______________ 100% ########################################libgcc_s.so.1 must be installed for pthread_cancel to work
Error: Error running

	--defaults-file=/opt/mysql/network/monitoring/mysql/my.cnf --user=mysql >
	/dev/null 2> /dev/null : child process exited abnormally

This was tried with 0.7.26 and 0.7.30 also. Running vanilla 5.0.28 works fine, so this is strange, even when running mysql_install_db.

Full mysql errfile is:
/opt/mysql/network/monitoring/mysql/scripts/mysql_install_db --defaults-file=/opt/mysql/network/monitoring/mysql/my.cnf --user=mysql
WARNING: The host 'OGSCHDB-011(BPV)' could not be looked up with resolveip.
This probably means that your libc libraries are not 100 % compatible
with this binary MySQL version. The MySQL daemon, mysqld, should work
normally with the exception that host name resolving will not work.
This means that you should use IP addresses instead of hostnames
when specifying MySQL privileges !
Installing all prepared tables
libgcc_s.so.1 must be installed for pthread_cancel to work
mysqld got signal 6;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 92783 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xf6f24e54, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
New value of fp=0x7e7f failed sanity check, terminating stack trace!
Please read http://dev.mysql.com/doc/mysql/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 0x8600a80 =
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
Installation of system tables failed!

Examine the logs in /opt/mysql/network/monitoring/mysql/data/ for more information.
You can also try to start the mysqld daemon with:
/opt/mysql/network/monitoring/mysql//bin/mysqld --skip-grant &
You can use the command line tool
/opt/mysql/network/monitoring/mysql//bin/mysql to connect to the mysql
database and look at the grant tables:

shell> /opt/mysql/network/monitoring/mysql//bin/mysql -u root mysql
mysql> show tables

Try 'mysqld --help' if you have problems with paths. Using --log
gives you a log in /opt/mysql/network/monitoring/mysql/data/ that may be helpful.

The latest information about MySQL is available on the web at
Please consult the MySQL manual section: 'Problems running mysql_install_db',
and the manual section that describes problems on your OS.
Another information source is the MySQL email archive.
Please check all of the above before mailing us!
And if you do mail us, you MUST use the ./bin/mysqlbug script!

How to repeat:
Install it and watch it die.
[15 Nov 2006 21:27] Andy Bang
We'll deliver a 64-bit service manager shortly after V1.
[13 Apr 2007 12:04] Carsten Segieth
mysqlnetwork- tested successfull on 'rh-x86-64' (RH4 x86-64) with 2 agents connected.
More tests of the Merlin server will follow soon, but the problem described in this bug here is solved.
[13 Apr 2007 13:06] Peter Lavin
Added to changelog.