Bug #24051 server inst - fix windows service names
Submitted: 7 Nov 2006 16:37 Modified: 22 Nov 2007 19:45
Reporter: Gary Whizin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version:1.0.0 OS:Microsoft Windows (windows)
Assigned to: BitRock Merlin CPU Architecture:Any
Tags: mer 120

[7 Nov 2006 16:37] Gary Whizin
Description:
There should be no white space in the windows service names:

Change from:

MySQL Network MySQL 
Tomcat

Change to:

MySQLNetworkMySQL 
MySQLNetworkTomcat

- - - -

NOTE: The service *description* field can have white space

How to repeat:
see above
[8 Nov 2006 21:08] Gary Whizin
Now there are only problems with the display names (the service names are OK):

Change from:                          Change to:
MySQL Network "MySQLNetworkTomcat"    MySQL Network Tomcat
MySQLNetworkApache                    MySQL Network Apache
MySQLNetworkMySQL                     MySQL Network MySQL

P.S. make sure to review that "MySQL" is capitalized correctly (it's our brand):

  incorrect: Mysql
  ONLY: MySQL (and sometimes mysql, depending on context)
[10 Nov 2006 15:59] Peter Lavin
In 0.7.28 the Tomcat service is still called:

MySQL Network "MySQLNetworkTomcat"
[10 Nov 2006 17:43] Peter Lavin
In 0.7.30 the Tomcat service is still called:

MySQL Network "MySQLNetworkTomcat"
[10 Nov 2006 18:44] Peter Lavin
In 0.7.31 the Tomcat service is still called:

MySQL Network "MySQLNetworkTomcat"
[11 Nov 2006 11:42] BitRock Merlin
MySQL Tomcat should display fine now. We are using 

mysqld-nt --install MySQLServiceName
apache.exe -k install ApacheServiceName

to create the MySQL and Apache services. I don't believe there is a way of specifying a different display name from the service name. Any suggestions?
[13 Nov 2006 21:54] Peter Lavin
As of 0.7.35 the Display names of the Apache and MySQL services in the
MS Management Console Window are:

MySQLNetworkApache
MySQLNetworkMySQL 

not yet changed to:

MySQL Network Apache
MySQL Network MySQL 

Tomcat and the Agent have spaces in their display names.

There is no description field for the Agent or for MySQL Network MySQL.
[13 Nov 2006 23:28] Peter Lavin
Regarding the comment:

"to create the MySQL and Apache services. I don't believe there is a way
of specifying a different display name from the service name. Any
suggestions?"

I don't know how it is done but the Agent and Tomcat both have display names (in the sense used by MS) that differ from the service name.

The Tomcat service is called "MySQLNetworkTomcat" and the service name displays in the console as "MySQL Network Tomcat".
[14 Nov 2006 15:59] BitRock Merlin
Tomcat and the agent use different install time options that allow us to control the display name when installing as a service. Apache and MySQL server seem to be lacking those procedures, those are the ones that I was asking feedback about.
[23 Nov 2006 13:11] Mark Leith
Indeed there is no way to set the display name when actually installing the MySQL service (at least, I am not sure of Apache). You can only set the service name and display name to the same thing. 

However, you can easily modify any service's display name after it has been installed anyway:

D:\mysql-5.0.19-win32>bin\mysqld-max-nt.exe --install MySQLNetworkMySQL --defaults-file=D:\mysql-5.0.19-win32\my-small.ini
Service successfully installed.

D:\mysql-5.0.19-win32>sc query MySQLNetworkMySQL

SERVICE_NAME: MySQLNetworkMySQL
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 1  STOPPED
                                (NOT_STOPPABLE,NOT_PAUSABLE,IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 1077       (0x435)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

D:\mysql-5.0.19-win32>sc config MySQLNetworkMySQL DisplayName= "MySQL Network MySQL"
[SC] ChangeServiceConfig SUCCESS

You could do exactly the same with the Apache installation as well..

Cheers,

Mark
[5 Jul 2007 21:14] Bill Weber
This was recently closed because we had switched to use mx/j for the repository and therefore did not install the mysqld service. However, we have now gone back to use mysqld and install the service, which (as before) does not have spaces - MySQLNetworkMySQL.
[28 Aug 2007 13:20] BitRock Merlin
Patch sent to Andy.
We have implemented making use of "sc" as requested. This approach won't work:
 - In Windows 2000
 - If the user uninstall and reinstall the services.
[29 Aug 2007 17:12] Keith Russell
Patch installed in versions => 1.2.0.7355
[30 Aug 2007 3:35] Bill Weber
The Tomcat service name is still MySQLNetworkTomcat (although the display name is now correct - MySQL Enterprise Tomcat). The MySQL service name and display name are both still MySQLNetworkMySQL. - Note that this is a duplicate of 30511, however keeping this open since it affects customer.
[30 Aug 2007 11:44] BitRock Merlin
We have made another round of testings, and the services are correctly changed to the new names, both "name" and "display name".

The XML project files for the server update should have the following BitRock build tag: 200708280541. Could you please confirm that on your side?
[5 Sep 2007 23:20] BitRock Merlin
Patch sent to Andy.
[6 Sep 2007 1:20] Keith Russell
Patch installed in version => 1.2.0.7481
[19 Nov 2007 14:00] Carsten Segieth
checked OK in 1.2.0.7879: 
- service names visible in service manager now have blanks in
- the "technical" names (which are used in RegDBO) not
[22 Nov 2007 19:45] Peter Lavin
Corrected in the body of the docs. Not added to the changelog.