Bug #23902 Agent Inst(Bitrock) -Validate HostName Does Not Work As Expected(???)
Submitted: 2 Nov 2006 17:16 Modified: 2 Nov 2006 19:11
Reporter: Punita Srivastava Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S2 (Serious)
Version:0.7.18 OS:Linux (linux)
Assigned to: Keith Russell CPU Architecture:Any

[2 Nov 2006 17:16] Punita Srivastava
Description:
When installing the Merlin agent on a linux machine, you are prompted for a host name (for mysqld server) followed by Y/N for 'Validate Hostname'. This did not work when I entered:
- Local  hostname = localhost/127.0.01
- Remote Host
--------------
When I started the agent later with the ini file having to monitor mysqld on a remote server, the log file gets a critical error as expected (as follows). This should have been found during 'hostname validation'?  

----------paste from agent.log on solaris agent box-----
(critical) connecting to mysql-server net-qa1 failed: Host 2006-11-02 06:28:36
'sol10-amd64-b.mysql.com' is not allowed to connect to this server
------------------------------end of paste--------------------

How to repeat:
Set up a Remote host monitoring while installing a Merlin agent.
[2 Nov 2006 18:23] Gary Whizin
see http://bugs.mysql.com/bug.php?id=23868
[2 Nov 2006 19:11] Keith Russell
Closing. This is a duplicate of 23868. Keith