Bug #23821 Reinstall MySQL after removing MySQL does not all root password change
Submitted: 31 Oct 2006 23:33 Modified: 6 Nov 2006 22:22
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.5 OS:Microsoft Windows (Windows)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: mysql administrator, password, root

[31 Oct 2006 23:33] Jared S
Description:
Hi,

I have recently unistall 5.0.27 and reinstalled 5.0.27 and can not change root password in administrator.

How to repeat:
Using Mysql 5.0.27 + GUI-TOOLs 1.2.5 BETA on WInXP 

1. Install and configure MYSQL 5.0.27
2. Unistall MySQL 5.0.27
3. RE-Install MySQL 5.0.27
4. Try to clear root password using Administrator

Administrator simply does not show ***** ***** where it should and it is not enabled.

Suggested fix:
Allow password change on root user after server re-install
[1 Nov 2006 12:27] Valeriy Kravchuk
Thank you for a problem report. Looks like MySQL Administrator problem for me.
[1 Nov 2006 15:33] Miguel Solorzano
Thank you for the bug report.
[2 Nov 2006 8:56] Mike Lischke
The handling of users and the hosts they can connect from has changed. Previously it was not consistent which host setting was changed when you select a user and change something. Look at the top of the page control. If you select "root" (which is by default installed without access from "any-host") you will get a line like:  "User without any-host (%) entry selected". The % entry can be edited by selecting the user entry itself. For other host entries you have first to switch on the host display (see either settings or the context menu in the user list). You'll also be asked to switch it on if you try to add or remove a host entry.

Previously, when selecting a user entry the % host info could be edited if it was there. If there wasn't such an entry then another entry was used, totally randomly (simply the first one which was in the mysql.user table). The latest change now makes this reliable and consistent. The % host entry can be edited when you select the user entry, other hosts by selecting their particular child node. If there is no % host entry then input boxes are disabled.

One can argue that password and additional info is not related to any host entry and should be enabled anyway, but this requires quite some changes in the code due to the way it is implemented there. Additionally, it *is* possible to assign different passwords to the same user but different host entries (which is unfortunately not possible with MA).
[6 Nov 2006 22:22] Jared S
Mike, could you just clarify my scenario. I like my users to log on as root no password.  So I now have to click 'Yes' to this new option dialog box in order to add a dummy % user.

No way to avoid this extra step? Since Config wizard wont allow blank password.
[7 Nov 2006 7:45] Mike Lischke
Jared, please understand that the issue tracker is not a support forum. Quick tip: once you enabled the host display in the user treeview select the root user and it will expand to a list of hosts allowed to connect. Usually this is only "localhost". Select this entry and you should be able to modify root's settings.
[28 Feb 2009 16:14] Michael Koons
This IS a support forum for the simple fact you should not be working for the company and this gentleman has answered my question also.
[17 Mar 2011 17:04] masi pay
This is 2011, MySql5.5.10
Since the bug still exists I can only assume developers of MySql have lover looked the bug reports(?) 

You may also want to look the reports on
http://bugs.mysql.com/bug.php?id=23861&thanks=3&notify=195