Bug #23606 --skip-name-resolve missing from SHOW VARIABLES (other skip options are shown)
Submitted: 25 Oct 2006 0:38 Modified: 25 Aug 2010 15:51
Reporter: Arjen Lentz Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S4 (Feature request)
Version:4.x, 5.0.22 OS:Any (any)
Assigned to: Paul Dubois CPU Architecture:Any
Triage: Triaged: D3 (Medium)

[25 Oct 2006 0:38] Arjen Lentz
Description:
The --skip-name-resolve variable is missing from SHOW VARIABLES, while other skip options are shown.

It's vital to be able to see from inside MySQL what the exact runtime configuration is, since it can come from a variety of sources (various config files, startup script & command line...)

Basically, please do a renewed check to see if all mysqld options are also visible  with SHOW VARIABLES. skip_grant_tables might be another one.

How to repeat:
mysql> show global variables like "skip%";
+-----------------------+-------+
| Variable_name         | Value |
+-----------------------+-------+
| skip_external_locking | ON    | 
| skip_networking       | OFF   | 
| skip_show_database    | OFF   | 
+-----------------------+-------+
[25 Oct 2006 2:12] Paul Dubois
It's not actually missing, because it's a server option only.
There is no associated system variable.
[25 Oct 2006 2:45] Arjen Lentz
Paul, that appears to be an obscure distinction - not of interest to users.
[25 Oct 2006 6:21] Valeriy Kravchuk
Thank you for a problem report. Yes, I also needed to check if it is really set, (some days ago) with SELECT - no way. So, I think, this is a reasonable feature request that should be implemented ASAP.
[23 Nov 2006 12:06] Magnus BlÄudd
The last variable in "my_option" struct called app_type can be used for application specific use. I would suggest the mysqld to include all variables from the "longopts" list into the output of SHOW VARIABLES unless they have a OPT_NO_SHOW_VARIABLES flag set. Or something like that.
[12 May 2008 16:24] Oliver Steinmetz
I want to bring this to your attention again. I also would like to see this in a newer sql version.
[24 Jul 2008 17:06] Andriy Denysenko
yes, really. DNS back-resolving slowed down our servers a lot. And now I use skip-name-resolve and it would be nice to be able to see it in show variables
[17 Sep 2008 2:48] Nils Meyer
Also ran into that today, it's hard to find out if this is actually set.
[25 Aug 2010 7:58] Beat Vontobel
I really agree with what has been said above: This is a tiny but critical feature. Any progress on that? Just had to dig out "tcpdump" to be really sure that mysql stopped its dns requests after the configuration change...
[25 Aug 2010 11:46] Valeriy Kravchuk
It seems it is implemented in current MySQL 5.5 already:

mysql> select version();
+----------------+
| version()      |
+----------------+
| 5.5.6-m3-debug |
+----------------+
1 row in set (0.00 sec)

mysql> show variables like 'skip%';
+-----------------------+-------+
| Variable_name         | Value |
+-----------------------+-------+
| skip_external_locking | ON    |
| skip_name_resolve     | OFF   |
| skip_networking       | OFF   |
| skip_show_database    | OFF   |
+-----------------------+-------+
4 rows in set (0.00 sec)
[25 Aug 2010 11:48] Valeriy Kravchuk
Also in current 5.1:

macbook-pro:5.1 openxs$ bin/mysql -uroot test
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 5.1.51-debug Source distribution

Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL v2 license

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show variables like 'skip%';
+-----------------------+-------+
| Variable_name         | Value |
+-----------------------+-------+
| skip_external_locking | ON    |
| skip_name_resolve     | OFF   |
| skip_networking       | OFF   |
| skip_show_database    | OFF   |
+-----------------------+-------+
4 rows in set (0.00 sec)
[25 Aug 2010 11:52] Valeriy Kravchuk
I do not see the fact that skip_name_resolve is now visible as server variable documented here, http://dev.mysql.com/doc/refman/5.1/en/server-options.html, so I think it is actually a documentation bug now.
[25 Aug 2010 12:23] Beat Vontobel
I can confirm that I was on a 5.0 server when I was looking for it today, Google brought me here when searching for "SHOW VARIABLES skip-name-resolve". The note that it's implemented in 5.1 would've helped me already. So just a left-over feature request that was not closed (and documented)... thanks for adding it to 5.1.
[25 Aug 2010 15:31] Paul Dubois
Looks like skip_name_resolve was added as a system variable in 5.1.46 and 5.5.5 by Bug#37168.
[25 Aug 2010 15:51] Paul Dubois
Thank you for your bug report. This issue has been addressed in the documentation. The updated documentation will appear on our website shortly, and will be included in the next release of the relevant products.