Bug #23476 DROP INSTANCE does not work
Submitted: 19 Oct 2006 19:01 Modified: 16 Jan 2007 20:45
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:Instance Manager Severity:S1 (Critical)
Version:5.1.12 BK OS:
Assigned to: Alexander Nozdrin CPU Architecture:Any

[19 Oct 2006 19:01] Alexander Nozdrin
Description:
DROP INSTANCE does not work. It seems, fix for BUG#12673 broke it.
The problem is that im_instance_conf.imtest is disabled, so the
bug was not discovered.

The bug will be fixed in scope of BUG#23215(STOP INSTANCE takes
too much time).

How to repeat:
1. Start IM;
2. Try to drop instance:
mysql> show instances;
+---------------+---------+
| instance_name | state   |
+---------------+---------+
| mysqld        | online  |
| mysqld2       | offline |
+---------------+---------+
2 rows in set (0.00 sec)

mysql> drop instance mysqld2;
ERROR 3001 (HY000): Cannot stop instance. Perhaps the instance is not started, or was started manually, so IM cannot find the pidfile.
[29 Nov 2006 16:45] Konstantin Osipov
Approved the second patch by email.
[16 Jan 2007 20:45] Paul Dubois
Noted in 5.1.15 changelog.

The Instance Manager DROP INSTANCE command did not work.