Bug #23099 Administrator exports without full CRLF
Submitted: 9 Oct 2006 7:40 Modified: 9 Oct 2006 14:44
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.4 RC OS:Microsoft Windows (WinXP)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: admin, carriage return, dump, export, lcr, lf

[9 Oct 2006 7:40] Jared S
Description:
When exporting my database using normal settings it shows up in notepad like 1 continuoes string.

How to repeat:
use admin to back any db and load using notepad

Suggested fix:
correct admin to wrok like it did in version 1.2.3 RC
[9 Oct 2006 12:49] Miguel Solorzano
Thank you for the bug report.
[9 Oct 2006 14:44] Mike Lischke
This is by intention. Because of the possibility to exchange dumps across platforms and for simplicity we decided to write Unix line breaks only. It also simplifies our unit test cases (which also are shared across all supported platforms) significantly. If you want to view your dumps outside of MA or QB then I recommend one of the better editors, which also support syntax highlighting. SciTE comes to mind (see http://www.scintilla.org), which is fast and free. Actually, you can use *any* editor, except Notepad (even Wordpad can handle the files).